Create permalinks to reviews (and use them in review RSS feeds)

RESOLVED DUPLICATE of bug 384798

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED DUPLICATE of bug 384798
10 years ago
2 years ago

People

(Reporter: Christopher Finke, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: 

The feeds for add-on reviews do not include GUIDs for each review in the feed, making it difficult to follow the feed with many popular feed readers.  Also, since the link element for each item in the feed links to the main review page for the add-on, new items cannot be distinguished from the old in that manner either.

Might I suggest either having permalink pages for individual reviews and using that URL as the GUID, or at least use something like <guid>review-{review_id}@addons.mozilla.org</guid>

Reproducible: Always

Steps to Reproduce:
1. Open a feed of reviews
Actual Results:  
Each item should have a unique identifier.

Expected Results:  
Each item does not have a unique identifier.

Comment 1

10 years ago
Confirming, having these would help. I have to look if permalinks are easily achievable (after all we need to point to the right page in the review list), otherwise I'll go for your other suggestion.

Also, the feed doesn't specify author names for reviews: That seems like a good thing to add too.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Depends on: 384798

Updated

10 years ago
Blocks: 377706
Summary: Add-on review feeds do not use GUIDs → Create permalinks to reviews (and use them in review RSS feeds)

Updated

10 years ago
No longer blocks: 377706

Updated

10 years ago
Blocks: 456418

Updated

10 years ago
Blocks: 453128

Updated

9 years ago
Blocks: 480002

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 384798

Updated

8 years ago
No longer blocks: 453128
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.