Ability to manually re-order tasks by dragging

RESOLVED DUPLICATE of bug 412514

Status

--
enhancement
RESOLVED DUPLICATE of bug 412514
10 years ago
a year ago

People

(Reporter: jeff, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 0.8

Would like to be able to re-order the tasks in the task pane simply by dragging a task up or down in the list. Currently (I think) it only sorts by title or by priority, and new tasks are added to the bottom of the list. I would like to be able to reorder them, in the order that is important to me.

As another option on top of the dragging method, you could somewhere add MOVE UP and MOVE DOWN buttons.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
You can sort the tasks by any column by clicking on the column header.
Summary: Feature request: Ability to manually re-order tasks by dragging → Ability to manually re-order tasks by dragging
(Reporter)

Comment 2

10 years ago
Yes you can sort by column, but that doesn't necessarily put them in the order that I want them in. Assuming all my tasks are of equal priority, I still want to sort them in the order that I want to work on them, without the hassle of having to add start dates and due dates.

Example:
I type my new task in the little text box window that adds a new task to the bottom of my list. I now grab it and drag it up to third on my list (because that's where I want it), and I'm done!
Also, whenever a task becomes more or less important, I simply drag it to a new spot in my task list and I'm done... easy peasy!!
OS: Windows XP → All
Hardware: PC → All

Comment 3

9 years ago
YES! This is a very important feature for a task list. This is crucial functionality to order the tasks for a given day.
This sounds like a reasonable request, requires some sort of local database though and a good data structure for the sort order. Also, we might need some UI for this. Right now the task list is sortable just by clicking on the columns. If we allow manual sorting via drag and drop, the user might accidentally click on the column headers and the manual sorting will be gone.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

8 years ago
@Fallen, you could either get rid of the other sort columns, or add an additional sort column (with an option to lock down) that assigns each task a number according to the user's sort priority after they drag an item.  That way if they accidentally click one of the other sort options, they could just click on the "number" column to re-order their tasks the way they had it set up.

Comment 6

7 years ago
I thought I wanted more detailed priority settings, and to be able to reorder the priority of tasks by focussing in the list and using ctrl-arrow up/down.

But this idea has enlightened me, particularly since most people might want to keep "Priority" as a semi-official / "serious" label; just because something is at the top of your list to do Right Now doesn't mean it's your 'top priority' in the grand scheme of things.

So, +1 for this idea. The extra column could be called simply "Order" or "Number".

As for data structure, is it incredibly naive to suggest that all that's needed is an integer? I have given some thought to how it would work when some tasks are not visible due to filtering and I think it should be alright.

Comment 7

7 years ago
I would also highly welcome an option to sort one's tasks simply by drag and drop (or UP and DOWN buttons alternatively).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412514
You need to log in before you can comment on or make changes to this bug.