cdec.water.ca.gov - Weather data plots truncated on right in non-IE browsers

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

Plots of hourly weather data on the California Department of Water Resources Web site are truncated on the right.  This is NOT a case of the plots extending to the right of the open browser window because there is no horizontal scroll bar and use of keyboard navigation arrows does not scroll.  

This problem is visible for several weather stations, not merely the Cheeseboro (CHE) station in the cited URL.  

Reproducible: Always

Steps to Reproduce:
1.  Go to the cited URL.  
2.  At the bottom of the page, select "Plot all CHE Sensors".  
3.  On the "Data Plots: CHEESEBORO" page, select any of the plot thumbnails.  
4.  At the top of the plot, note the indicated span.  
5.  On the browser menu bar, go to [View > Use Style > None].  
Actual Results:  
After step #3, the plot is truncated on the right relative to the span seen in step #4.  After step #5, the entire plot is visible (possibly with horizontal scrolling).  

Expected Results:  
The entire plot should be visible over the span indicated.  

A plot of air temperatures at CHE over a 10-day period has 36 HTML errors.  That page references 7 external CSS file.  One CSS file is 404.  Two other CSS files each have 1 CSS error.  

Note that spoofing Firefox does not correct the problem.  Instead, the plotting pages were apparently designed only for IE.  Spoofing IE7 does not correct the problem.  Using the actual IE7 does not show this problem.  Therefore, this does not appear to be a case of invalid sniffing; this bug is not a candidate for blocking bug #334967.  

I submit this bug report because the general attitude at the California Department of Water Resources is that I should be using IE.  They are not interested in fixing bugs that impact non-IE browsers.  Nevertheless, I did send an E-mail to their Webmaster.
(Reporter)

Comment 1

10 years ago
I was somewhat hasty in writing the last paragraph of the Description, in my criticism of the California Department of Water Resources.  Someone from the Department responded to my E-mail.  They are indeed looking to fix this.  

However, they are focusing on the fact that my monitor resolution is 800x600.  They assert that I could set my resolution to 1024x768 and then zoom if I need things larger.  Some applications do not have a zoom capability, and zooming does not make images larger (at least with SeaMonkey).  

I have explained to them that, with 800x600 resolution, the display is okay (1) when viewed in IE and (2) when viewed with CSS disabled in SeaMonkey.  This now being the weekend, I don't expect a reply until possibly Monday.  

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: [cdec.water.ca.gov] Weather Data Plots Truncated on Right for Gecko Browsers → cdec.water.ca.gov - Weather data plots truncated on right in non-IE browsers
(Reporter)

Comment 2

7 years ago
Almost three years later, this is still a problem.

Comment 3

3 years ago
Everything seems to be working just fine.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.