partial install causes major problems on mac os x

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Liam K., Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061913 Firefox/3.0
Build Identifier: http://www.mozilla.com/en-US/firefox/

I checked the version of Firefox on someone I know's computer, and it said Firefox 2.0.0.2. I tried to update to Firefox 3 for them, but Help > Check for Updates was disabled (probably because she did not have permissions on her computer, as it is a work computer). I downloaded the Mac version from mozilla.com, and followed the instructions as best as I could. I dragged the Firefox icon to her dock, and then opened the Applications folder. However, dragging the icon into there gave a permissions error. (Clicking on the Firefox icon in her dock still opened Firefox 3 successfully.) I looked it up and tried to repair permissions on her computer, but it still didn't work, so I guessed that another account on her computer had permissions, but she didn't have the password readily available. Later, she tried rebooting, and her computer booted up very slowly. After that, it showed the select user screen, which it normally doesn't show. Her desktop loaded very slowly and refreshed itself frequently, and any program opened would take almost an hour to load.

Reproducible: Always

Steps to Reproduce:
1. Download Firefox 3 on a Mac OS X, in a profile with no root permissions.
2. Drag the icon to the dock.
3. Repair permissions.
4. Reboot.
Actual Results:  
Computer hangs and has major issues.

Expected Results:  
The partial update should either be removed, or update the Applications folder itself.

I need support with this, should I contact Mozilla Support?
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
"repair permissions" might be the real problem.  Firefox itself should have no impact on OS X, but changing file permissions improperly can cause all sorts of badness...

support is an option, but I suspect you caused problems with the os structure...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Errr... that's disappointing.

I googled the permissions error I got. and on the Apple support website it said I should try repairing permissions. It didn't sound harmful...

I guess my best bet would be to contact Apple support... :(
You need to log in before you can comment on or make changes to this bug.