[OS X 10.4] Applet is not visible on Firefox 3.0.

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Bhavesh Patel, Unassigned)

Tracking

({qawanted, regression})

3.0 Branch
PowerPC
Mac OS X
qawanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15])

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

A simple applet with different java component (JLabel, JSplitPane, JButton), is not visible on the screen in Firefox 3.0. In the status bar a message is displayed "Applet <applet Name> started", but on screen applet is not visible. This works fine on previous version of Firefox 2.0.0.11 and on safari, on the MAC with same JRE.
To make the applet visible we need to resize the Firefox browser. 

Reproducible: Always

Steps to Reproduce:
Attached a zip file for sample applet.
1. Unzip the zip file in any folder.
2. Open Firefox 3.0 browser.
3. Open the .html file in Firefox.

Applet will be loaded but it will not be visible.
Actual Results:  
Applet is not visible on the screen.

Expected Results:  
Applet has to be visible on the screen.
(Reporter)

Comment 1

10 years ago
Created attachment 325925 [details]
Attached a zip file which contain .jar and .html file to test applet.

Zip file contain .jar and .html file to test the applet and .jar file contain source code for the applet.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Does it also happen with a spoofed user agent string?
I could have sworn that the applet didn't start before I spoofed it to Firefox 2, but now the applet also works with the original user agent string.
Ah well, I think I just tested Firefox 3.1.
I just retested on Windows Vista and it works fine with the latest 3.0 build so one can ignore comments 1 and 2. 
(Reporter)

Comment 5

10 years ago
It dose not work on Macintosh. I have tested on different firefox versions it dosen't work from Firefox 3.0 RC1. On windows platform it works fine.

Updated

10 years ago
Keywords: regression
(Reporter)

Updated

10 years ago
Severity: major → blocker
(Reporter)

Updated

10 years ago
Severity: blocker → major
(Reporter)

Comment 6

10 years ago
Please verify this bug.
Severity: major → blocker

Updated

10 years ago
Keywords: qawanted
Severity: blocker → major
This applet works fine for me on OS X in Firefox 3 and today's Firefox
1.9.0-branch nightly (what will become Firefox 3.0.2).

No Java applets work on OS X in current mozilla-central nightlies (on
the trunk, aka the 1.9.1-branch, what will become Firefox 4).  But
that's a separate issue.  See bug 435334 and bug 444963.

I'll attach a screenshot in my next message.

I tested on OS X 10.5.4.  I'm using Java version J2SE 5.0, which is
the default.
Created attachment 329359 [details]
Screen shot of this bug's applet in Firefox 3 on OS X
(Reporter)

Comment 9

10 years ago
Can you please verify this on MAC OS X 10.4.11 Using JRE version 1.5.0_13
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

Comment 10

10 years ago
Also WFM using Leopard. Tiger issue?
I tested this using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1, which is the next release coming up, running with JRE version noted in Comment 9 and the test applet renders fine.
(Reporter)

Comment 12

10 years ago
Still applet is not visible on version 3.0.1 with the same JRE.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Comment 13

10 years ago
Not fixed on my configuration:

Installed JRE 1.5.0_13

Mozilla/5.0 (Macintosh; U ; PPC Mac OS X 10.4; en-US; rv: 1.9.0.1) 
Gecko/2008070206
Firefox/3.0.1

Reproducible: always.

I'll verify the same configuration as mentioned in comment #11

Comment 14

10 years ago
This seems to be a Tiger issue only. See comment 9 and comment 13.

Comment 15

10 years ago
Yes, seems to be a Tiger only issue. 

Can this problem be confirmed from the Mozilla side ? 

So far - see Comment 11 - it was only said to work, while both Bhavesh - see comment 12 - and me still encounter this problem. 

Updated

10 years ago
Summary: Applet is not visible on Firefox 3.0. → [OS X 10.4] Applet is not visible on Firefox 3.0.

Comment 16

8 years ago
Do you still see this problem using the most recent versions of all components (application, plugins and add-ons)?

If you do not, please close the bug with resolution set to WORKSFORME. If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [closeme 2010-09-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.