formatblock misbehaves in contentEditable DIV

RESOLVED WORKSFORME

Status

()

Core
Editor
P3
normal
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: liucougar, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.1 +
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: midas)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

if a contentEditable DIV is nested in another DIV (which is not contentEditable), formatblock commands generate undesired result

Reproducible: Always

Steps to Reproduce:
1. load the test case attached
2. place caret after the "a" character in the editable area
3. press the format button
Actual Results:  
an extra line is added after the "a" character, and the resulting html is: a<p><br></p>

Expected Results:  
no extra line should be created, and the resulting html should be <p>a</p> or <p>a<br></p>

in the test case, if removing the outer DIV, it works as expected, however, in most real cases, a contentEditable is not direct child of body.
(Reporter)

Updated

10 years ago
Component: General → Editor
Product: Firefox → Core
(Reporter)

Comment 1

10 years ago
Created attachment 325963 [details]
testcase for formatblock bug in contentEditable DIV

Updated

10 years ago
Keywords: testcase
Whiteboard: midas

Updated

10 years ago
Blocks: 237964
QA Contact: general → editor

Comment 2

10 years ago
Don't see any duplicates of this, and it seems to be incorrect behavior. Confirming.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a1pre) Gecko/2008062402 Minefield/3.1a1pre

Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Flags: blocking1.9.1?
Not blocking 1.9.1.  Wanted1.9.0.x+ & 1.9.1+.   P3.  
Flags: wanted1.9.1+
Flags: wanted1.9.0.x+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Priority: -- → P3
Version: unspecified → Trunk
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19 ID:2010031422, WFM against Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110724 Firefox/8.0a1 ID:20110724030752

=> resolving WFM?

Comment 5

7 years ago
Yes!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.