If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cache long URL's for reports, charts, and searches

RESOLVED DUPLICATE of bug 15809

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 15809
9 years ago
9 years ago

People

(Reporter: miketosh, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: 

A workaround to support IE's severe limitations would be as follows:

Create a table, URLS, with token,url,who,creation_ts.
When performing searches, add a simplified url to the table with a random token.
Provide a link to redir.cgi?token=xxxx to each of the 'action' links (change cols, change multiple, csv) in order to provide a shorter URL for queries
Create a page, redir.cgi, that accepts a token from the uri and redirects the user to the stored url from the db that matches the given token

I know this sounds JUST like tinyurl.com, and it should.  That is a great concept.

Reproducible: Didn't try
(Reporter)

Updated

9 years ago
Version: unspecified → 3.1.4

Comment 1

9 years ago
(In reply to comment #0)
> 
> Provide a link to redir.cgi?token=xxxx to each of the 'action' links (change
> cols, change multiple, csv) in order to provide a shorter URL for queries
> Create a page, redir.cgi, that accepts a token from the uri and redirects the
> user to the stored url from the db that matches the given token

If you redirect the user to the stored URL, you're still going to hit the limits imposed on you by your web browser/server.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 15809
You need to log in before you can comment on or make changes to this bug.