Theme browser doesn't show compatible themes

VERIFIED FIXED in 5.0.9

Status

P3
normal
VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: baz, Assigned: wenzel)

Tracking

Details

(URL)

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
The current theme browser doesn't filter or show themes compatible with your version (or OS platform) unlike other listing views on the site.

This view shows no "install" button, and therefore no indication whether the available version is compatible.

To check compatibility the user must click through to each theme's page for
every available theme individually. Ugh.
(Reporter)

Comment 1

11 years ago
See also bug 440226
wenzel suggested graying-out the incompatible themes, rather than outright removing them from the view -- thoughts?

Comment 3

10 years ago
My preference would be to add a checkbox to enable listing of compatible themes only (so to get the real top-10 themes for my current browser).
Yeah, that might work better, since iirc Fred said doing the compat check will be a bit of a perf hit.

Comment 5

10 years ago
(In reply to comment #3)
> My preference would be to add a checkbox to enable listing of compatible themes
> only (so to get the real top-10 themes for my current browser).

See also bug 437496
Target Milestone: --- → 5.0.7

Updated

10 years ago
Target Milestone: 5.0.7 → 5.0.8

Updated

9 years ago
Priority: -- → P3

Updated

9 years ago
Assignee: nobody → fwenzel

Updated

9 years ago
Target Milestone: 5.0.8 → 5.0.9
(Assignee)

Comment 6

9 years ago
osunick: Do we have any UI for this?
(Assignee)

Comment 7

9 years ago
I could implement some JS+CSS according to comment 2, if you like.

Comment 8

9 years ago
Please do! Thanks in advance, Alfred
(Assignee)

Comment 9

9 years ago
Created attachment 394260 [details]
Screenshot

This is what I have so far. Is this too subtle?
(Assignee)

Updated

9 years ago
Blocks: 510192
(Assignee)

Comment 10

9 years ago
Created attachment 394263 [details] [diff] [review]
Patch, rev. 1

This adds 30% transparency to incompatible add-ons in the list.

I also filed a followup bug to add an overlay to these add-ons that allows users to figure out what version range the add-on *is* compatible with, and also makes it easier to realize what translucency means in this context.

For now though, I think this is a good solution, as people who care can look at it, all others can choose to ignore it.
Attachment #394263 - Flags: review?(clouserw)
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
It's an interesting idea - I'm not sure how accessible it is, but I'd be willing to try it in this case.  If an add-on is greyed out (and particularly if there is an overlay when I mouse over it) I would expect to not be able to click on it and see the detail page though.  However, without the overlay I think this is too subtle to notice.
(Assignee)

Comment 12

9 years ago
Not sure if I'd disable the link altogether. That might upset people who want to inform themselves about the add-on in spite of their current browser not supporting it.

Also, do I interpret your comment correctly as, you want to r- it, not because the code isn't good, but because you don't think this should be deployed *without* the overlay at first?
I'm just fishing for more ideas, but yeah, I think the overlay is necessary.
I agree with Wil- we need an overlay.
(Assignee)

Updated

9 years ago
Attachment #394263 - Attachment is obsolete: true
Attachment #394263 - Flags: review?(clouserw)
(Assignee)

Comment 15

9 years ago
Over to Neil then for mockup / sketch / playdoh model.
Assignee: fwenzel → neilio
(Assignee)

Updated

9 years ago
Status: ASSIGNED → NEW
(Assignee)

Updated

9 years ago
Duplicate of this bug: 510192

Comment 17

9 years ago
Created attachment 394549 [details]
Compatible themes bar

Here's the mockup we chatted about in IRC, with stephend's text in it.

Hex colour for the bar is #b5d9e5. Unless we really need to make this look identical in IE I think we should just use CSS rounded corners, but that's just my 2 cents. :)

If you need graphics let me know.

Updated

9 years ago
Assignee: neilio → fwenzel
(Assignee)

Comment 18

9 years ago
(In reply to comment #17)
> Here's the mockup we chatted about in IRC, with stephend's text in it.

I thought this is for the followup bug. This bug adds an overlay, no?

Comment 19

9 years ago
Created attachment 394555 [details]
Overlay graphic

Sorry, I got confused. Here's the overlay graphic (made larger in case you need to do sliding doors with it for text/l10n expansion) and the mockup is here:

http://snaps.beatnikpad.com/icompatible-themes-overlay-20090814-153622.png
Attachment #394549 - Attachment is obsolete: true

Comment 20

9 years ago
(In reply to comment #19)
> http://snaps.beatnikpad.com/icompatible-themes-overlay-20090814-153622.png

From comment 10 / bug 510192, this should also state the compatibility range, not just the fact that it's incompatible.
(Assignee)

Comment 21

9 years ago
Created attachment 394823 [details] [diff] [review]
Patch, rev. 2

This patch adds an overlay on top of the "faded" list item.
Attachment #394823 - Flags: review?(clouserw)
(Assignee)

Comment 22

9 years ago
Created attachment 394825 [details]
Fix Screenshot

A screenshot of the fix.
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
Comment on attachment 394823 [details] [diff] [review]
Patch, rev. 2

This is looking good.  I don't like how long the notice stays on the screen when I move my mouse away, but I guess that's just my preference.
Attachment #394823 - Flags: review?(clouserw) → review+
(Assignee)

Comment 24

9 years ago
I made it faster. That didn't work for me yesterday, but I was probably doing something wrong.

In r49393 and r49394.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
Tested using:

* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20
* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.13) Gecko/2009073022 Firefox/3.0.13
* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
* Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090820 Namoroka/3.6a2pre
* IE 7, Safari 4, Opera 9.64 (just to double-check for layout/style regressions)

mozwebqa: I could use sanity-checking here, thanks :-)
Pretty confident this is fine -- verified FIXED.
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.