Rendering glitch with flash objects (small border below)

RESOLVED DUPLICATE of bug 439836

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 439836
10 years ago
10 years ago

People

(Reporter: Alberto Gonzalez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Arch Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Arch Firefox/3.0

I've noticed a problem with Firefox 3 when inserting a flash object in a page. It seems to insert a small border below the object that creates an ugly visual glitch. Take this trivial code as example:

<body bgcolor="Green">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="798" height="223">
  <param name="movie" value="test.swf">
  <param name="quality" value="high">
  <embed src="test.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="798" height="223"></embed>
</object>
<table bgcolor="Black" border="0" width="798" cellpadding="0" cellspacing="0">
  <tr>
    <td height="20">&nbsp;</td>
  </tr>
</table>
</body>

Between the flash object and the table with black background there should be no space, but with Firefox 3 I see a green border in between. This didn't happen with Firefox 2 or with any other browser I've tested.

Reproducible: Always

Steps to Reproduce:
1. Paste code above on a blank HTML document
2. Open it with Firefox 3
3. 
Actual Results:  
There's a green border between the flash object and black table.

Expected Results:  
The black table should be right below the flash object without any border in between.
(Reporter)

Comment 1

10 years ago
By the way, a workaround for anyone who finds this problem is to wrap the object in a div set with the same height as the object. Something like:

<div id="flashObject" style="height: 400px;">
<object width="550" height="400">
<param name="movie" value="somefilename.swf">
<embed src="somefilename.swf" width="550" height="400">
</embed>
</object>
</div>

This will eliminate the border added at the bottom.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439836
You need to log in before you can comment on or make changes to this bug.