If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-On Manager Unnecessarily Connects to services.mozilla.org on every launch

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: Jared, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080419 Ubuntu/8.04 (hardy) Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080419 Ubuntu/8.04 (hardy) Firefox/2.0.0.14

During my testing of various extensions with Firefox 3, I've noticed that every time I load the Add-On Manager Firefox attempts to connect to services.mozilla.org.  Aside from the unnecessary waste of bandwidth (although admittedly a small amount), this is particularly annoying because it prompts me for my proxy credentials on every view of the Add-On Manager.  So:

1. install extension
2. proxy prompt
3. restart
4. proxy prompt
5. launch add-on manager to configure options
6. proxy prompt
7. launch add-on to remove extension
8. proxy prompt

Now, keep in mind that I'm not attempting to do anything online at all in the above scenario - I install the extension, test/configure it, and remove it, and yet I have to go through four separate authentication prompts because the Add-On Manager is trying to connect to services.mozilla.org every single time it's displayed.

Why does this occur, and can it be stopped?

Reproducible: Always

Steps to Reproduce:
1. Click Tools, Add-Ons
Actual Results:  
Firefox has, on its own, initiated an unwanted connection to services.mozilla.org.

Expected Results:  
The Add-On Manager should be displayed without first attempting to connect to services.mozilla.org and therefore prompting me for my proxy credentials.
This was done intentionally in order to make the results in the Get Add-ons list available as quickly as possible.

Comment 2

9 years ago
This is a feature of the new Firefox 3 addons manager (Get Add-ons panel) - you
can disable it via extensions.getAddons.showPane -> false in about:config. You
can read more about it @ http://madhava.com/egotism/archive/005018.html 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

9 years ago
Thanks, setting that preference solved my problem.  However...

This is a pretty nifty new feature.  I'd read about it in the past, but didn't associate that it was what was causing this problem as I never at any point clicked on the new Get Add-ons panel.  Would it perhaps make more sense to pull the content for this panel when it is selected, and therefore specifically requested, rather than ALWAYS connecting to services.mozilla.org and downloading information whenever the add-on manager is displayed?  That way, users can easily access the information whenever they want it, just as easily as they do now, but it doesn't make any unnecessary connections in the background without the user's knowledge.

I guess you could consider this a feature request.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.