attachment filename saved with extra text

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
11 years ago

People

(Reporter: Brade, Assigned: rhp)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Sometimes when I get a message with an attachment, I see "(not downloaded yet)" 
(or something like that) in the drop down list of attachments.  When I save the 
file(s), the file name includes "(not downloaded yet)".  I expect the filename to 
be saved with the filename sent unless I pick a different name.

Unfortunately our mail server is currently down so I can't provide you with more 
details/exact descriptions.

Updated

19 years ago
QA Contact: lchiang → pmock
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 1

19 years ago
This looks like a problem with the file picker or something very Mac specific, 
because this works as it should on Windows. Can you describe exactly what 
happens after you select the file to save?

- rhp

Comment 2

19 years ago
I can reproduce a similar problem in today Mac commercial seamonkey build 
2000-070608-m17 installed on G3/400 MacOS 9.04.

Steps to reproduce problem:
1) On Mac 4.7, sent yourself a mail message that contains a jpeg attachment.
   Be sure the file you're attaching doesn't have a file extension, i.e  .JPG
2) Launch semonkey
3) Open mail
4) Log into mail
   I was running on IMAP
5) Select the mail message you sent from 4.7
6) Click on the paperclip icon
   The attachment name should be called "...(not downloaded yet".
7) Select the attachment name
   It should bring up the "Open/Save Attachment"
8) Click on the radio button to "Open It" and click OK
   The dialog entitled "Unknown File Type" dialog appears
9) Click ont he "Save File" dialog
   The "Save" dialog appears.
   The default file name given is "INBOX>2012"

   It may crash to macsbug when it click OK to continu.
* I was not able to reproduce problem on win32 or linu so far.

Comment 3

19 years ago
M18 and nsbeta3.
Keywords: nsbeta3
Target Milestone: M17 → M18
(Assignee)

Updated

19 years ago
Keywords: correctness
(Assignee)

Comment 4

19 years ago
Well, I just tried this out on a QA Mac machine with a mail message with an 
attached 250K Excel spreadsheet. It first gave me the choice to run or save the 
attachement and when I selected save, it gave me the file name alone (not the 
"Not Downloaded") part. Saved it as expected.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
Verified as worksforme.  I was not able to reproduce problem using the build  
macos commercial seamonkey build 2000-092911-mn6 installed on G3/400
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.