No prompt to Save as Draft after Quiting the Browser

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Ninoschka Baca, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
Build 2000-06-27-08M17: NT4, Mac 9.04
Haven't tried Linux

Problem: Create a new message from the 3pane, go to the Browser to Quit and no 
prompt appears asking "Do you want to save the message in a Draft folder?".

Steps to reproduce:
1. Open Mail
2. Select the "New Msg" button
3. Type some text
4. Open the Browser
5. Select File|Quit

Actual Results: All the windows close and no warning to save the message in a 
Draft folder appears.

Expected Results: Before the entire application is closed a prompt should appear 
stating "The message has not been sent. Do you want to save the message in the 
Draft Folder?".

Additional Information
a. It does work in the following scenario:
- Open Mail
- switch to the Browser
- select File|New|Message and type some text
- switch back to the Browser 
- Select File|Quit (A prompt appears asking if you want to save the message to a 
Draft folder)
(Reporter)

Comment 1

18 years ago
Thanks to Jeff Tsai for finding this problem.
This should be fixed because he can result in data loss.
Keywords: nsbeta3
QA Contact: lchiang → pmock

Updated

18 years ago
Target Milestone: --- → M18
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: correctness

Updated

18 years ago
Keywords: relnote2

Updated

18 years ago
Keywords: mail2

Comment 2

18 years ago
Please verify that the problem continues to exist.  We think there is another 
bug for this problem and it may have been fixed already.
Whiteboard: [nsbeta3+]
(Assignee)

Comment 3

18 years ago
This is working fine for me. I followed the step and I correclty get the prompt dialog asking me if I want to save the 
message. You must have done more than just typed a recipient address else we won't bother saving the message (like 
does 4.x)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Build 2000-08-07-14M18: NT4, Linux 6.0
Build 2000-08-07-22M18: Mac 9.04
Verified Worksforme. I tried it on all three platforms and it's working now.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.