mail news is linking to rdf too much.

VERIFIED WONTFIX

Status

MailNews Core
Backend
P3
normal
VERIFIED WONTFIX
18 years ago
10 years ago

People

(Reporter: Judson Valeski, Assigned: Alec Flett)

Tracking

({arch, embed})

Trunk
Future
x86
Windows NT
arch, embed

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
See #43895 for more info.
(Reporter)

Comment 1

18 years ago
+'ing
Keywords: arch, embed, nsbeta2
Whiteboard: nsbeta2+
(Assignee)

Comment 2

18 years ago
*** Bug 44091 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
the only places we should be linking against rdf are msgbaseutil and address 
book - Adding putterman to CC so he can verify my claim.

Also adding ducarroz to the CC because I will need his help with the mac
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 4

18 years ago
as long as it builds there's no reason why we need to do this.
(Reporter)

Comment 5

18 years ago
I'm not sure how mail/news is built out, but we definately want to minimize 
these static links (on a module level) from a footprint/bloat standpoint. Does 
all of mail/news build into a single shared lib?

Comment 6

18 years ago
sorry, my comment was meant to be that as long as we build without linking 
against this library then making this change is fine.  I haven't tried it and 
for all I know that could be leftover from when we did need to link against it.
(Assignee)

Comment 7

18 years ago
ok, so it looks like either we have to figure out how to re-export nsRDFResource
from msgbaseutil.dll, or make msgbaseutil a static library itself (which I'm
beginning to think is The Right Thing anyway)
(Assignee)

Comment 8

18 years ago
jud this is turning out to be a whole lot more work than we thought at first.
I'd like to take this off the nsbeta2 train... the rdf library we're linking to
is VERY small (my DEBUG version is 41k) - we're not linking against RDF itself,
just a static utility library.
On Mac, we are not linking against RDF. However, we are including 
nsRDFResources.cpp directly into the Mac project and we are also linking against 
MsgUtil.lib (as static)
(Assignee)

Comment 10

18 years ago
ok, sounds like mac is doing the right thing.
(Reporter)

Comment 11

18 years ago
mail news actually isn't even part of our current embedding solution, yanking
from beta2
Keywords: nsbeta2
Whiteboard: nsbeta2+

Comment 12

18 years ago
moving to future.
Target Milestone: M17 → Future
(Assignee)

Comment 13

18 years ago
I'm marking WONTFIX. We can get past this by switching to resource delegates,
but I think putterman already has a bug on this.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 14

18 years ago
Can someone verify this?
AFAIK, the new outliner code doesn't use any (or much) RDF in the thread pane
(we still use it in the folder view).  But based on the comments in this bug,
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.