switching windows with Cmd + ` doesn't work when focus is in a text field

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: Pete, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_4_11; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

When opening multiple windows the switching between windows with the combination Mac + ` doesn't work at first. If the cursor is in an active form field you have to click outside of the field first and then it works.



Reproducible: Always

Steps to Reproduce:
1. open 2 windows
2. 2nd window with a form field put cursor in field
3. use Mac + ` to switch windows


Actual Results:  
Mac entered ` in the field rather then switching windows

Expected Results:  
switch between windows

Comment 1

10 years ago
I have the same problem with my custom key setting.

It happens if any part has got the keyboard focus like the address bar, the message box in Chatzilla, this textarea while I type, or Firebug search box.

IOW, it seems to be quite down the stack.

I am under MacOSX 10.5.3

Comment 2

10 years ago
This is related to bug 417466 which is supposed to be fixed.

https://bugzilla.mozilla.org/show_bug.cgi?id=417466

I suspect the solution applied then might need to be ported to controls/widgets...

Comment 3

10 years ago
I imagine they steel the focus from gecko, iow manage the keyboard events before gecko enters the dance.

I must say I have no idea if the comment here above could be correct, just a feeling.
Assignee: nobody → joshmoz
Component: Keyboard Navigation → Widget: Cocoa
Product: Firefox → Core
QA Contact: keyboard.navigation → cocoa
Summary: switching of windows with Mac + ` doesn't work → switching windows with Cmd + ` doesn't work when focus is in a text field
This WORKSFORME in a recent 3.0.x build on 10.5.6/Intel (en-US).  Are people still seeing this?

Comment 5

10 years ago
Still there for me on 3.05 and 10.5.5/Intel.

I'll check when updated to 10.5.6.

Comment 6

10 years ago
I upgraded to OSX 10.5.6 and FF 3.0.6 and I still see the bug.

Updated

9 years ago
Assignee: joshmoz → nobody
The issue seems to be resolved. Marking as WORKSFORME since no one can reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.