Bookmarks are being saved in history though they shouldn't

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: quilax, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0

When clicking on the star in the adress bar accidentally and after that click "cancel", the bookmark is saved anyway in the "recently added bookmarks" folder.

Reproducible: Always

Steps to Reproduce:
1. Open any website
2. Click the star in the adress bar and click cancel
3. Watch the folder "recently added bookmarks"
Actual Results:  
The non-existing bookmarks are shown in the folder "recently added bookmarks"

Expected Results:  
Nothing, the bookmark should not be shown anywhere.

Comment 1

11 years ago
What I believe is happening is that the bookmakrs is being saved to you unsorted folder.  You can verify this in several ways.
1) Navigate to the page where the incident is happening and see if the star is yellow.
2) Open the Libary, Bookmarks > Organize, and then click the "Unsorted Bookmarks" folder and look for the page.

If this is happening, then there are several ways to stop it.
1)Double click the start to save the bookmark where you want it. Clicking it once automatically saves it to unsorted.
2)If accidentally clicked star, click again and this time select Remove bookmark.  Click cancel will not delete the bookmark.

So to summarize you are saving the bookmarks to unsorted and they are showing up in Recently Bookmarked.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> What I believe is happening is that the bookmakrs is being saved to you
> unsorted folder.  You can verify this in several ways.
> 1) Navigate to the page where the incident is happening and see if the star is
> yellow.
> 2) Open the Libary, Bookmarks > Organize, and then click the "Unsorted
> Bookmarks" folder and look for the page.
> 
> If this is happening, then there are several ways to stop it.
> 1)Double click the start to save the bookmark where you want it. Clicking it
> once automatically saves it to unsorted.
> 2)If accidentally clicked star, click again and this time select Remove
> bookmark.  Click cancel will not delete the bookmark.
> 
> So to summarize you are saving the bookmarks to unsorted and they are showing
> up in Recently Bookmarked.
> 

Nope I think that's not the problem. Why should a bookmark be saved in the unsorted folder when clicking the "cancel" button BEFORE saving it!?
When you click the star a bookmark is automatically created (this is a feature to enable single-click bookmark saving), then when you click the second time you have the option of sorting it and adding tags, or (on the top) of removing the bookmark, cancel doesn't remove it, as the bookmark is made before you click the second time, cancel only cancels any actions made subsequent to saving it (i.e. specifying a folder or adding tags).

If the problem is that on the first click the popup shows, that would be a different bug, otherwise,

--> INVALID

Comment 4

11 years ago
(In reply to comment #3)
> When you click the star a bookmark is automatically created (this is a feature
> to enable single-click bookmark saving), then when you click the second time
> you have the option of sorting it and adding tags, or (on the top) of removing
> the bookmark, cancel doesn't remove it, as the bookmark is made before you
> click the second time, cancel only cancels any actions made subsequent to
> saving it (i.e. specifying a folder or adding tags).
> 
> If the problem is that on the first click the popup shows, that would be a
> different bug, otherwise,
> 
> --> INVALID
> 
Horrible feature. Was it just too hard to click on bookmarks & click, Bookmark this page?

Comment 5

11 years ago
notyou: if you would like to complain to the designers, feel free to at <http://feedback.mozilla.org>, not here.  This bug is for the problem experience by the reporter not complaining about new features in Firefox 3.

Thank you.
(In reply to comment #4)
> Horrible feature. Was it just too hard to click on bookmarks & click, Bookmark
> this page?

it was indeed, this is workink as expected
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.