There is no official 64-bit version of Firefox

RESOLVED DUPLICATE of bug 469654

Status

()

Firefox
Build Config
--
enhancement
RESOLVED DUPLICATE of bug 469654
10 years ago
9 years ago

People

(Reporter: blenheimears, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008062103 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008062103 Firefox/3.0

There is no official X86-64 version of Mozilla Firefox or Thunderbird. It is possible to compile a 64-bit version of Firefox, as I have done. 64-bit is quickly becoming the new standard. It would also be nice if there were official versions for other processor architectures such as MIPS, ARM, SPARC, PPC, etc. I know it is possible to run 32-bit i386 binaries on X86-64 or one of the other processor architectures (with QEMU), but this is really just a backward compatibility mode and it should be avoided if possible.

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
N/A

Expected Results:  
There should be an official 64-bit version.

It would also be nice if Mozilla officially supported more operating systems (or at least provided unofficial binaries) for OSes such as *BSD, Solaris, IRIX, BeOS, etc. An important program like Firefox should officially support more than just 3 OSes.

Comment 1

10 years ago
There are "contrib" builds (builds provided by people outside of mozilla.com), but at this moment only the OS/2 and Solaris versions has been added. Note that in most cases, the builds are provided by the vendors directly, using their own distribution network (Ubuntu, Red Hat, ...)

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/latest/contrib/

I look around for the actual bug-report about this, but the problem is your words "official builds". You can't expect that mozilla.com will provide official builds for all different os/cpu/platform combinations. But there should be some more info on that download page I think.

Updated

10 years ago
Blocks: 237202

Comment 2

9 years ago
Please change the title to read: "Provide official 64-bit releases"

The most obvious low-hanging fruit is 64-bit binaries for Windows. Both Flash and Java are beta testing 64-bit versions of their plugins as I write this. You can't expect them to test against FireFox for compatibility unless you put out *official* builds of these. Think about it from their point of view. Why would they want to waste time on 3rd-party builds which might or might not be used by users.

Comment 3

9 years ago
FYI: Java6 update 12 which is about to be released will include a 64-bit plugin.
(In reply to comment #2)
> You
> can't expect them to test against FireFox for compatibility unless you put out
> *official* builds of these. Think about it from their point of view. Why would
> they want to waste time on 3rd-party builds which might or might not be used by
> users.
Actually JRE 6u2 EA works with an unofficial build which is distributed on
http://www.mozilla-x86-64.com/ .
That said, I fully agree to your enhancement request.

Comment 5

9 years ago
I assume you meant Java 6 update 12 (not 2)?

Comment 6

9 years ago
IMO Mozilla should start putting out native 64 bit builds with some publicity surrounding the whole thing. Java is working fine on the native 64bit builds and adobe most probably have an internal version of 64bit flash waiting for mozilla/opera to step out.

The fact that unofficial builds are running so well should alleviate most of the concerns and marking the builds as experimental would remove the liability from the mozilla guys.

Updated

9 years ago
Blocks: 482143
Status: UNCONFIRMED → NEW
Component: General → Build Config
Ever confirmed: true
QA Contact: general → build.config

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469654

Comment 8

9 years ago
Isn't bug 469654 about Windows? What about Linux "amd64" architecture? (which is probably more common in Linux than x64 is in Windows)

Updated

9 years ago
No longer blocks: 482143
You need to log in before you can comment on or make changes to this bug.