Open All in Tabs - "replace current tab and append the others" behavior makes no sense

RESOLVED DUPLICATE of bug 395024

Status

()

RESOLVED DUPLICATE of bug 395024
11 years ago
10 years ago

People

(Reporter: Andreas.Klauer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061916 (Gentoo) Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061916 (Gentoo) Firefox/3.0

The behaviour of 'Open All in Tabs' for bookmarked folders changed in Firefox 3 in a way that makes it confusing and useless to most users.

Old behaviour: 
remove all current tabs, create new tab for each bookmark in folder

New behaviour:
overwrite current tab with first bookmark, create new tabs for the others

Usage example:
I have two bookmark folders, one called 'Webcomics' which contains all the webcomics I like, and one called 'Forums' which contains all the forums I read frequently.

In Firefox 2, I'd open 'Webcomics' with 'Open All in Tabs', and when I'm done reading the new daily comics, I'd go for 'Forums', which would close all Webcomics (since I'm done with them), and go for the forums instead. I also have additional folders for news, anime, and the like. 

In other words, a folder represents a topic, and when I'm done with browsing one topic, I want to continue to the next. Forgetting all tabs of the old topic and replacing them with all tabs of the new topic was a very efficient way to do this; within 15 minutes on each morning I was up-to-date regarding all topics that interest me (read all webcomics, checked for replys on the forums, etc).

In Firefox 3, instead of efficient browsing this is what happens:
I open webcomics in all tabs and read them.
Then I open forums in all tabs.
This kills one of my webcomics, replacing it with the first forum. 
Then it adds tabs for all other forums, and leaves the other webcomics alone.

If the current tab was somewhere in the middle, I'll now have 5 webcomic tabs followed by 7 forum tabs followed by another 10 webcomic tabs: it's chaotic.

Please restore the old behaviour and make it the default. It's the most useful and logical: after all, you group bookmarks in a folder, because you don't want them to be mixed with other bookmarks. What good is it to mix them with other bookmarks by making 'Open All in Tabs' a mixing tabs with tabs behaviour.

I read some bugs that were concerned about data loss due to 'Open All in Tabs'. Regarding that, it's okay to have the back button work in tabs. For a real protection against data loss, Firefox would have to understand 'Open All in Tabs' as an atomic operation that can be undone with a single 'Undo'.

However the point is that data loss is what I want when 'Open All in Tabs'. I'm done with one topic, I want to close the old topic and to proceed to the next topic.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
A simple way to get back your old behavior is to right-click on any one tab and click "close other tabs".

See bug 175124 and bug 395024 for the current implementation.
(Reporter)

Comment 2

11 years ago
Ah, sorry, I should've commented on #395024 then.

I know I can just close the tabs myself (means at least two unnecessary extra clicks every time) or install an extension that restores the old behaviour. However from my point of view, Firefox should stick with the old behaviour by default, because the new one is simply useless (inevitably leads to mixed tab chaos).

In the other bug reports I have not seen a single example of usage where the 'replace current tab and append the others' behaviour would make any sense at all.
>Ah, sorry, I should've commented on #395024 then.

Just dupe this over to that bug then and follow the discussion there.

Comment 4

11 years ago
Why does closing the tabs yourself mean extra clicks?  If you close each comic as you're done reading it, that's as many clicks as switching tabs would be.
Summary: Open All in Tabs usability issue in Firefox 3 → Open All in Tabs - "replace current tab and append the others" behavior makes no sense
(Reporter)

Comment 5

11 years ago
That's true - if you read all tabs and close them immediately afterwards. That's rarely ever the case though - think of webcomics that you know update only every two days or once a week, or forums that you're not interested in today. It'd be tedious to create even more subfolders for additional classification.

Also in terms of usability, closing a tab when what you actually want to do is switch to another tab (not necessarily in the order the tabs were opened with), is not very intuitive.

Plus I don't know what the new behaviour could be useful for. Assuming someone doesn't close tabs, he can't use 'Open all in tabs' either. It'll end up in chaos or just too many tabs in total. As far as I'm aware no one has yet described a usage scenario where the current behaviour 'replace current tab append all others' would come in handy, like the (from my point of view very efficient) browsing by topic sort of way.

My point is not about clicks, it's usability. If something needs more clicks while being more intuitive at the same time, I'm all for it. In this case here we have it the other way around though... not intuitive, not useful for anything, plus more clicks than before.

Comment 6

11 years ago
I think the problem "only append" is that it sorta requires having 0 tabs open before you do it.

Comment 7

10 years ago
I agree with the original complaint, this is not working like previous versions. The previous functionality should be restored.

Steps to reproduce.

1. open several bookmarks in tabs
2. Bookmark all tabs to a folder (Control-Shift-D)
3. close all existing tabs and open several different bookmarks in tabs making sure to have more than one tab open.
4. Either from bookmarks toolbar or from bookmarks menu highlight the newly created folder. Scroll to bottom of context and select "Open All in Tabs"

Previous behavior would replace all existing tabs with the new ones to the point of opening more than were already present or closing some if there were more present than in the saved folder.

Current behavior is to replace the last tab with the first one of the saved folder then open new tabs for each remaining bookmark in the folder.

For instance, if you have saved sites 1, 2, and 3 to a folder.  Then close them and open sites 4, 5, and 6.  Then choose to open 1, 2, and 3 with the option "Open All in Tabs" previous behavior was to replace 4, 5, and 6.  Current behavior leaves you with tabs 4, 5, 1, 2, 3. Enhancements should never break previous funcitonality.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395024
You need to log in before you can comment on or make changes to this bug.