Same-page links are not shown and do not work

RESOLVED DUPLICATE of bug 102695

Status

()

--
major
RESOLVED DUPLICATE of bug 102695
11 years ago
11 years ago

People

(Reporter: hans-georg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Q312461; .NET CLR 1.0.3705; InfoPath.1; .NET CLR 2.0.50727; .NET CLR 1.1.4322; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Some of the links in the "Table of contents for this article" do not show as links (underlined) and do not function.

Reproducible: Always

Steps to Reproduce:
1. Open the URL.
2. Move the mouse pointers over the links in the "Table of contents".
3. Additionally, click on the links.
Actual Results:  
At least two links are not underlined and do not work.

Expected Results:  
All links should be underlined, should be clickable, and should jump down to the respective chapter in the same page.

Works correctly in Internet Explorer.

I have changed the anchors (<a name="...">) from name= only to both id= and name= to no avail.

I suspect a display localization problem, because the second link reacts in a vertically offset way to the mouse pointer.
The table of contents is a DIV styled with float:right and it is
overlapped by the DL block later in the document that contains the
books, "Moss, Cynthia" etc.  This DL is styled position:relative.
According to CSS 2.1 stacking context rules
http://www.w3.org/TR/CSS21/zindex.html
the (positioned) DL is above the (float) DIV.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102695
You need to log in before you can comment on or make changes to this bug.