Sort Order for Bookmarks - Unchanged after changing

RESOLVED DUPLICATE of bug 405108

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 405108
10 years ago
10 years ago

People

(Reporter: Morton Lee Cohen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Click Bookmarks
Click Organize Bookmarks
Click Bookmarks Menu - Left Window
Click Views Click Sort
Click Sort By Name
Click Sort Click A > Z Sort Order

No way to Apply or Save Changes that I see.


Reproducible: Always

Steps to Reproduce:
1.Click Organize Bookmarks
2.Click Bookmarks Menu - Left Window
3.Click Views Click Sort
4.Click Sort By Name
5. Click Sort Click A > Z Sort Order
Actual Results:  
No Changes have been made or saved

Expected Results:  
Sort order for Bookmarks changed for the way it was Sorted or changed by the User.

Tried while viewing the Bookmarks Sidebar and not viewing the BookMarks Sidebar. No Changes saved.
That sorting is done in the Library, when you click sort the main window sorts the bookmarks... is that not working?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> That sorting is done in the Library, when you click sort the main window sorts
> the bookmarks... is that not working?

Not sure for the purpose of the Library Sort, if you can't save changes. That's why I reported the bug. 

Yes, I can Right-click in the Main BookMark Sidebar and click Sort by Name and have it sorted, then I don't understand the purpose Organize Bookmarks function or why it is in Firefox at all, confusing Users.

The purpose of the library sort is as its menu title suggests, View-->Sort, is to change the _view_ of the bookmarks, i.e. how it appears in the Library, right-clicking and sorting is to actually sort the items themselves.

(btw you can right-click and sort in the Library as well)

Comment 4

10 years ago
I think that behavior is different from FF2. Any idea why it was changed?
(In reply to comment #4)
> I think that behavior is different from FF2. Any idea why it was changed?

Well the only difference I see from ff2 is that the sort order isn't maintained in the Library itself, i.e. if you click View-->Sort-->Sort By Name in the Library and then shut it and reopen it it won't be sorted by name, but both ff2 and ff3 don't actually sort the bookmarks when using the view menu.

The aforementioned is probably a valid bug, although I'm not sure if that is what the reporter intended.

OS should be changed to All as I am using Vista.

Comment 6

10 years ago
(In reply to comment #5)
> Well the only difference I see from ff2 is that the sort order isn't maintained
> in the Library itself, i.e. if you click View-->Sort-->Sort By Name in the
> Library and then shut it and reopen it it won't be sorted by name, but both ff2
> and ff3 don't actually sort the bookmarks when using the view menu.

But that _is_ an important distinction. Firefox 2 saved the changes.
Sorry for the misunderstanding I thought this bug was about the actual sort order of the bookmarks, as it is (i.e. the way you described the bug) it is a 

dup of bug #405108
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405108
You need to log in before you can comment on or make changes to this bug.