ignoring 'onChange' in <SELECT>

VERIFIED DUPLICATE of bug 3322

Status

()

Core
Event Handling
P3
minor
VERIFIED DUPLICATE of bug 3322
19 years ago
19 years ago

People

(Reporter: pete.nelson, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I tried out raptor today - and was quite impressed!  One problem I saw was on
our homepage [ http://www.ci.saint-paul.mn.us ] which uses <SELECT> menus:

<SELECT name="url"
onChange="window.open(this.options[this.selectedIndex].value,'_top')">
<option value="/mayor/">
About Saint Paul
<option value="/mayor/">
Mayor's Page
<option value="/mayor/stateofcity99.html">
State of the City
...
</SELECT>

The 'onSelect' didn't work.  We also use a 'Go' button to call 'navigate.cgi'
for older browsers, or browsers without javascript.  When I pressed the 'Go'
button, it took me to the CGI, redirected me to the right page, but, it didn't
replace the history, so hitting 'Back' on raptor gets me stuck at the CGI.

Updated

19 years ago
QA Contact: 4590 → 4015

Comment 1

19 years ago
not core javascript

Updated

19 years ago
Component: JavaScript → Event Handling
QA Contact: 4015 → 4137

Updated

19 years ago
Assignee: norris → vidur

Comment 2

19 years ago
This is the DOM, not JS.

Updated

19 years ago
Assignee: vidur → pollmann

Comment 3

19 years ago
Eric, I believe the onchange() problem is yours.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
Yup.  This is a dup of bug 3322.

*** This bug has been marked as a duplicate of 3322 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.