Hebrew bookmarks appear as Jibrish (looks like an Encoding problem)

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Baruch, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

All of my bookmarks which are in Hebrew, appear as Jibrish (an examle: îåòãåï äàåôðåòéí äéùøàìé).


Reproducible: Always

Steps to Reproduce:
1.Add abookmark from a page that has a Hebrew Title
2.Clicking the Bookmarks menu
3.Seeing Jibrish
Actual Results:  
Bookmakrs appear as Jibrish in stead of Hebrew

Expected Results:  
Show the bookmakrs correctly in Hebrew
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Works fine for me, I can't really see your hebrew input in the description, so there may be a problem with your hebrew support (fonts, etc.), here's a line of hebrew to try this with

שלום אחי

Renaming a bookmark with that text works for me, try it in safe mode:
http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 2

10 years ago
Now it is working...
I think importing the bookmarks from an HTML file made all the problems, while importing them directly from IE seems to work
 10X
Well, if you still have the html file, can you attach it here, BTW FF3 now uses json files to import and export bookmarks. Otherwise just mark this bug WORKSFORME.
(Reporter)

Comment 4

10 years ago
Hey Natch, I would rather send you the HTML file by mail and not attach it here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.