FF3 always starts with maximized window size

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: juergen.fenn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; de; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; de; rv:1.9) Gecko/2008061004 Firefox/3.0

FF2 I could have start up on Mac OS 10.4.11 to a certain winwod size. I set this by dragging the window frame to the required size and format. After restart, FF2 remembered this and restored its window size.

This does no longer work in FF3.0 which always starts up with a maximized window size.

There seems to be no way to change this.

Thanks for fixing!

Reproducible: Always

Steps to Reproduce:
1.Drag the Firefox window to a certain size.
2.Close Firefox.
3.Restart. It will create a maximized window.
Actual Results:  
It will create a maximized window.

Expected Results:  
I expected to get the window size I had before closing Firefox, as was the case with FF2.

FF3 should behave like FF2 did.

FF3 is rather nicely integrated into Mac OS X. However, there is no other application on my system that starts with a maximized window... so this should be fixed rather sooner than later because it's quite unlike anything you will find on a Mac...

Thanks in advance!
You could try deleting the file localstore.rdf in your profile; it may be corrupted.
http://kb.mozillazine.org/Corrupt_localstore.rdf
(Reporter)

Comment 2

10 years ago
Thanks, Ria, for you early reply. This works indeed. My problem is solved.

BTW, thanks for the great work on Firefox3, I upgraded this afternoon, and I like it a lot!

Regards,

J├╝rgen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.