Firefox crashes when opening a 4th Firefox window

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: larry, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

334.14 KB, application/pdf
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I may have 2 or 3 Firefox windows open. When I try to open a new window, the screen freezes, goes white and then Explorer indicates that the program has stopped working. This has happened on 5 separate occasions with 3 windows open.

Reproducible: Always

Steps to Reproduce:
1.Have 3 Firefox windows open.
2.Try to open a 4th window.
3.Window opens and tries to connect to homepage, but the screen goes pale white.
4.Explorer then indicates that Firefox has stopped working and will be closed.
5.All windows are closed.
6.When opening Firefox again, fortunately it saves all the tabs for each previously opened window.
Actual Results:  
Explorer closes Firefox.

Expected Results:  
It should have opened the 4th window to the homepage.

This has chappened 5 times, all with the same results. "Firefox has experience4d a preoblem and will be closed now."
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Do you have the same problem if you run firefox in the firefox safemode ?
. http://kb.mozillazine.org/Safe_mode
(Reporter)

Comment 2

10 years ago
Created attachment 326146 [details]
Test in Safe Mode

No problems in safe mode.

Comment 3

10 years ago
Test each of the add-on's you have loaded in Firefox to see if any of them is causing the problem.

Comment 4

10 years ago
I again tested with Firefox 3 with many add-on's and more then 10 windows are opened each with more then 5 tabs. Its working fine. And No problem in Safe Mode. 
(Reporter)

Comment 5

10 years ago
All I can say is that if I have 3 windows open (Firefox) with at least 5 tabs, inevitably Firefox will crash. I can't seem to predict anymore exactly how, but I consistently get a crash of the program.
I don't get your crash report window often, but yesterday I did and I submitted it, so you should have a record of it.
I can't speak for your tests, but this is a consistent and plaguing problem that I am experiencing.
I don't want to go back to 2.00.14 because I think the new features in 3.0 are great, so I've limited myself to two open windows. But I shouldn't have to, especially if I'm researching a complex issue or there are numerous links from a window.
(Reporter)

Comment 6

10 years ago
I'd love to do that sort of testing, but I have a business to run and literally have no time to do all the tests on the permutations and combinations of the 17 addons I use, but that would take hours and hours, which I don't have.
The addons I use are:
Adblock Plus
Adblock Plus: Element Hiding
AI Roboform Toolbar
All in one Sidebar
Cooliris Previews
CustomizeGoogle
Download Statusbar
FlashGot
Link Alert
NoScript
Passive Cache
PDF Download
Sage Too
Wizz RSS News Reader
WOT
Yahoo Toolbar
Yapta
>I don't get your crash report window often, but yesterday I did and I submitted
>it, so you should have a record of it.
Then type about:crashes as URl in Firefox and post the crash id.

If this works in the safemode then this is usually not our problem but it could be still a bug in Firefox but the addon-name which is causing that is needed and I don't want to install your list of addons but it's possible that the crash ID will help.

Comment 8

10 years ago
Well I tried to download few of the add-ons which u ve installed. Well I want to let you know few of these add-on are not in ff3. its only available in ff2... Like WOT, PDF down loader i m not able to get. .

But much better it will be if we get the crash id as Mattias has stated.


marking wfm (works in the safemode)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.