Closed Bug 441096 Opened 15 years ago Closed 15 years ago

deb packaging is busted.

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: dougt, Assigned: blassey)

Details

Attachments

(1 file)

when doing a "make deb" in the obj dir, i see the following:


cd debian/xulrunner/usr/local; cat ../../../../dist/xulrunner-1.9.1a1pre.en-US.linux-arm.tar.bz2 | bunzip2 -c  | tar -x
cat: ../../../../dist/xulrunner-1.9.1a1pre.en-US.linux-arm.tar.bz2: No such file or directory

bunzip2: Compressed file ends unexpectedly;
        perhaps it is corrupted?  *Possible* reason follows.
bunzip2: Invalid argument
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

/home/dougt/builds/mozilla/mobilebase/xulrunner/config/nsinstall -D debian/xulrunner/usr/share/dbus-1/services/
cp debian/xulrunner.service debian/xulrunner/usr/share/dbus-1/services/org.mozilla.xulrunner.service
dh_shlibdeps; fakeroot dh_gencontrol; fakeroot dh_md5sums; dh_builddeb
dpkg-gencontrol: warning: unknown substitution variable ${shlibs:Depends}
dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
warning, `debian/xulrunner/DEBIAN/control' contains user-defined field `Maemo-Icon-26'
dpkg-deb: building package `xulrunner' in `../xulrunner_1.9.1a1pre_armel.deb'.
dpkg-deb: ignoring 1 warnings about the control file(s)
make[1]: Leaving directory `/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
OS: Mac OS X → Linux
Hardware: PC → All
Do you really want $(DEPTH)/../../../../dist/ there?
OS: Linux → Mac OS X
Hardware: All → PC
OS: Mac OS X → All
Hardware: PC → All
the tar.bz2 that the package target makes is located in the dist dir of the obj dir (hence the $(DEPTH)).  Because of the "cd $(DEBDESTDIR)/usr/local;" on that line we're 4 levels below the directory of the make file, which is what sets $(DEPTH).  

Perhaps it would be more exact to have ../../../../$(DEPTH)/dist ? 
Comment on attachment 326357 [details] [diff] [review]
adds $(depth) to keep that path relative 

Ah, ok, just didn't quite follow that there. Yeah, I think I'd prefer ../../../../$(DEPTH)/dist
Attachment #326357 - Flags: review?(ted.mielczarek) → review+
With the last patch:

dougt@dougt-ubuntu:/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner$ make deb

<snip>

cd ../../dist && tar -c --owner=0 --group=0 --numeric-owner --mode="go-w" -f - xulrunner | bzip2 -vf > xulrunner-1.9.1a1pre.en-US.linux-arm.tar.bz2
  (stdin):  3.201:1,  2.500 bits/byte, 68.76% saved, 36014080 in, 11252249 out.
make[2]: Leaving directory `/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
/scratchbox/tools/bin/make tools
make[2]: Entering directory `/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
Makefile:107: FULL_NSPR_CFLAGS=-I\${includedir}/stable
make[2]: Leaving directory `/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
make[1]: Leaving directory `/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
make[1]: Entering directory `/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
Makefile:107: FULL_NSPR_CFLAGS=-I\${includedir}/stable
/home/dougt/builds/mozilla/mobilebase/xulrunner/config/nsinstall  /home/dougt/builds/mozilla/src/xulrunner/installer/debian .
/scratchbox/tools/bin/misc_runner: /targets/links/scratchbox.config: No such file or directory
make[1]: *** [deb] Error 126
make[1]: Leaving directory `/scratchbox/users/dougt/home/dougt/builds/mozilla/mobilebase/xulrunner/xulrunner/installer'
make: *** [deb] Error 2
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
verified with beta3
Status: RESOLVED → VERIFIED
sorry for bug spam.
Many of the bugs which are marked invalid, I see comments telling it occurred in one version or other. But later it was fixed due to 1) by backingout the patch which made regression or 2) by fixing some other bug.
So if we can identify the bug/patch/reason then we should state that and mark those as FIXED. If not mark as WORKSFORME in that case.
You need to log in before you can comment on or make changes to this bug.