Proxy: Setting a SOCKS host proxy does not work anymore

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
--
major
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Joshua Lenmarc, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

This used to work in version < 3.

Reproducible: Always

Steps to Reproduce:
1. Set a SOCKS (v5) proxy. SOCKS host: localhost, port: 10080
2. Click OK, then another OK to close the Options window.
3. Browse a site that requires the SOCKS tunnel, does not work.
4. Open Options window and SOCKS settings windows (Tools > Options > Advanced > Network > Settings)
Actual Results:  
The previously set SOCKS host and port disappear. SOCKS host is blank, port is 0.

Expected Results:  
The previous SOCKS settings should be retained.

Comment 1

9 years ago
Did you edit users.js or use any external configuration utility?

Updated

9 years ago
Summary: Setting a SOCKS host proxy does not work anymore → Proxy: Setting a SOCKS host proxy does not work anymore
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

9 years ago
No external configuration and no edit of users.js

I discovered that SOCKS5 now works (step 3) but...

the settings (host and port) are NOT retained in the "Sock host:" fields.

Steps to reproduce:
1. Set a SOCKS (v5) proxy. SOCKS host: localhost, port: 10080
2. Click OK, then another OK to close the Options window.
3. Browse a site that requires the SOCKS tunnel, does not work. --> now works
4. Open Options window and SOCKS settings windows (Tools > Options > Advanced >
Network > Settings)
Actual Results:  
The previously set SOCKS host and port disappear. SOCKS host is blank, port is
0.

Comment 3

9 years ago
Okay, so, here's the next step:

use about:config to search for "network.proxy.socks"

When it is blank, it should say: default,string,(blank)...

then make the changes in the config... then look at about:config again...

then open a new window and surf... (socks should work in a new window...)

then quit... restart... look at about:config...

Also, go look in your profile's "prefs" directory. Something may have put something in there, even if you didn't. Search all the files for "socks". I know you are on windows, in mac/unix, it would be "grep socks *"...

Updated

9 years ago
Blocks: 448634
(Reporter)

Comment 4

9 years ago
I can see it from about:config but in Tools > Options > Advanced >
Network > Settings fields. I have a feeling it is something related to my addons, extensions or plugins. We can cancel this report. Thanks for the help.

Comment 5

9 years ago
RESOLVED:

So, the Prefs UI is not the same as about:config? 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

9 years ago
Yes correct. Do you want to debug? I would be willing to help.

Comment 7

9 years ago
Can you attach screen snapshots of both?
(Reporter)

Comment 8

9 years ago
Created attachment 333708 [details]
Settings are in about:config but not in the Preferences window

Comment 9

9 years ago
yikes.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

9 years ago
NEW.

Making some progress here.

The immediate problem is that saving prefs works and if you quit and restart, all proxy works, but then reopening the UI looks blank (and then saving w/ "ok" again erases everything...).

Can you confirm that?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 11

9 years ago
Correct. I can confirm that it is exactly what is happening. 

Comment 12

9 years ago
Is this still a problem? In Firefox 3.5 and a recent SeaMonkey build the proxy prefs show up as expected when I launch them and open the relevant pref pane.

Comment 13

7 years ago
This looks like it can be closed as being fixed in the meantime.

No feedback from the reporter the last time being asked (2009-04) and works for jag, me and others.
wfm with Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110109
Firefox/4.0b9pre SeaMonkey/2.1b2pre and a socks proxy.
Status: NEW → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.