Closed Bug 441172 Opened 13 years ago Closed 13 years ago

Crash [@ nsACString_internal::GetReadableBuffer] on start-up, after installing Firefox 2 over existing Firefox 3 installation

Categories

(Firefox :: General, defect)

2.0 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 423226

People

(Reporter: martijn.martijn, Unassigned)

Details

(Keywords: crash)

Crash Data

My brother encountered this.
He wanted to try out the new Firefox 3, then he noticed some change in Firefox 3 that he didn't like, so wanted to revert back to Firefox 2.

Steps to reproduce:
- Install Firefox 3 using the default settings
- Install Firefox 2 using the default settings
- Start-up Firefox 2

Result:
Crash

Talkback ID: TB46790427H
nsACString_internal::GetReadableBuffer  [mozilla/xpcom/string/src/nsTAString.cpp, line 472]
NS_CStringGetData_P  [mozilla/xpcom/build/nsStringAPI.cpp, line 268]
brwsrcmp.dll + 0x2e17 (0x01642e17)
brwsrcmp.dll + 0xe259 (0x0164e259)
brwsrcmp.dll + 0xe87f (0x0164e87f)
CallTypeSniffers  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 698]
CallPeekFunc  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 128]
nsInputStreamPump::PeekStream  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 140]
nsHttpChannel::CallOnStartRequest  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 752]
nsHttpChannel::ProcessNormal  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 924]
nsHttpChannel::ProcessResponse  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 846]
What version of firefox 2 did he downgrade to. Connected to bug 423226 perhaps?
FF 2.0.0.14.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 423226
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsACString_internal::GetReadableBuffer]
You need to log in before you can comment on or make changes to this bug.