javascript:print() reverses typed text in another window's location bar

RESOLVED DUPLICATE of bug 407379

Status

()

--
minor
RESOLVED DUPLICATE of bug 407379
10 years ago
10 years ago

People

(Reporter: scottku, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

Opening a print dialog with javascript:print() causes the URL bar in other windows to behave strangely.

Reproducible: Always

Steps to Reproduce:
1. Open two firefox windows
2. Type type "javascript:print()" into the address bar or click a link which calls javascript:print()
3. While the print dialog is open, edit text in the other windows URL bar
Actual Results:  
Typing text into the URL bar appears right to left instead of left to right. Text selection in the URL bar also is broken. 

Expected Results:  
The URL bar should behave normally.

When you click "Cancel" in the print dialog, the problem goes away.  The problem does not occur when you select "File, Print..." in the browser.
(Reporter)

Comment 1

10 years ago
I've also been able to reproduce this bug on Windows.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Confirmed. I assume this is a regression from Firefox 2.
Might be interesting to know the regression range.
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
QA Contact: general → general
Hardware: PC → All
Version: unspecified → Trunk
I see this problem also in very old builds so I can't get a regression range from this.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407379
You need to log in before you can comment on or make changes to this bug.