Junk mail filters not working on messages that do not match a filter (IMAP)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
9 years ago

People

(Reporter: atr, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-04-22)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Junk mail filters are not catching junk mail that ends up in Inbox folder.  This only related event that I can think of is that I manually edited the msgFilterRules.dat file for _one_ account.  However, the Junk mail controls are now not working on _any_ account for Inbox messages.

ALSO, when I manually mark a message as Junk, it _always_ goes to the Trash even though my Junk mail rules say "Move to Junk folder."

In the one account with heavy filtering, Junk mail _is_ being detected in every folder but the Inbox.

I have tried turning all Junk options off and on.

I have tried a reinstall of this version of Thunderbird.

I have _not_ deleted the training.dat file, since the controls _are_ working for mail that ends up in folders other than the Inbox.



Reproducible: Always

Steps to Reproduce:
1. Wait for SPAM message to appear in Inbox
2. Manually mark as junk
3. Check junk mail folder
Actual Results:  
1. SPAM message is not marked as junk and remains in Inbox
2. Marking as SPAM causes message to disappear 
3. Message does not appear in Junk folder--it gets moved to Trash

Expected Results:  
1. SPAM message would be identified as SPAM and be moved immediately to Junk folder
2. Marking message as SPAM should cause it to go to Junk folder
3. Message should appear in Junk folder after being marked as SPAM

Comment 1

9 years ago
Andy, do you see this issue in version 3?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Whiteboard: closeme 2010-04-22
RESOLVED INCOMPLETE per lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.