Browser does not come up...thread safe assertions in a row

VERIFIED WORKSFORME

Status

()

P3
blocker
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: racham, Assigned: ruslan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
In the commercial debug tree I have......I am not able to bring the browser up 
[even after turning the activation off...It is not an activation bug 
bugscape bug 1335...]

There seems to be some thread issues (cacheManager, nsNetNoduleMgr) that are 
causing the app to not show up...

Assigning to judson.
(Reporter)

Comment 1

19 years ago
Please note that you will go to bugzilla bug when you click on the hyperlink 
in the previous update....i was referring to a bugscape bug..

Transfering the status of that bug to this one..

Probably judson didn't change anything to cause this. I am assigning this to him 
as I found all those assertions in nsNetModuleMgr and judson has the maximum 
contribution to that file..

Severity: normal → blocker
Keywords: dogfood
Summary: Browser does not come up...thread safe assertions in a row → Browser does not come up...thread safe assertions in a row
(Reporter)

Comment 2

19 years ago
Console dump :

Initialized app shell component {2e759801-6ac0-11d3-a02d-006008d20c70}, 
rv=0x00000000
WARNING: No disk cache present, file 
d:\dbgbuild\mozilla\netwerk\cache\mgr\nsCacheManager.cpp, line
160
###!!! ASSERTION: nsNetModuleMgr not thread-safe: 'owningThread == 
NS_CurrentThread()', file d:\dbg
uild\mozilla\xpcom\base\nsDebug.cpp, line 432
###!!! Break: at file d:\dbgbuild\mozilla\xpcom\base\nsDebug.cpp, line 432
(Reporter)

Comment 3

19 years ago
Created attachment 10764 [details]
stack trace
(Reporter)

Comment 4

19 years ago
Steps to reproduce :

1. just create a new profile (netscp6 -profilemanager)
2. launch browser with that profile

Comment 5

19 years ago
-> gagan
Assignee: valeski → gagan

Comment 6

19 years ago
*** Bug 44097 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
Shouldn't this have been a smoketest blocker? Something has got to have changed
to make this stop working. I am marking this smoketest since someone must have
forgotten to run the precheckin tests :(
Keywords: smoketest

Comment 8

19 years ago
dumb question= how do I turn off activation?

Comment 9

19 years ago
saw this in commercial on windows
I went in and commented out the assertion in nsDebug, and started ok

on mac, I seem to hang, but no assertions
also commercial

but, i was able to start after trying an old profile, perhaps just got lucky?

Comment 10

19 years ago
ok leaf sez works on release. So no smoketest... this still needs to be resolved
ASAP though, since most developers would be running debug. 
Keywords: smoketest
(Reporter)

Comment 11

19 years ago
activation can be turned off by setting the following pref to false.

browser.registration.enable in all-ns.js.

Comment 12

19 years ago
Note dup bug 44097 is on the Linux platform.

Comment 13

19 years ago
Putting on [dogfood+] radar. 
Whiteboard: [dogfood+]

Comment 14

19 years ago
ruslan is investigating this. Looks like the activation component may not have 
an event queue. 
Assignee: gagan → ruslan
(Assignee)

Comment 15

19 years ago
This works for me btw on debug build. Can the owner of that feature talk to me 
so we can see what's wrong?
(Reporter)

Comment 16

19 years ago
I don't see it on my debug commercial build anymore either. This should be a 
worksforme now. 
(Assignee)

Comment 17

19 years ago
Marking works for me. If somebody sees it - pls break it in the debugger and see 
what it does and call me as well.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 18

19 years ago
verified:
WinNT 2000071108
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.