Closed Bug 441384 Opened 12 years ago Closed 3 months ago

after installation of ff3, xp has a duplicate "firefox" entry in the "open with" context menu for .htm and html. files

Categories

(Firefox :: Shell Integration, defect, minor)

3.0 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: eiwveoitcosuotu, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0

when opening the context menu of a .htm or .html file, xp shows

"firefox"
"internet explorer"
"firefox"
"notepad"
and so on

ff has a duplicate entry in recommanded progs. as well

Reproducible: Always

Steps to Reproduce:
1. choose a .htm or .html file
2. right click
3. open with->
Actual Results:  
as described

Expected Results:  
a single ff entry

ff2 was installed before, and there was a single entry

i installed ff3 with ff2 still installed, not running
Version: unspecified → 3.0 Branch
Attached image screenshot
And in the task manager? Is there a firefox.exe always running?
no, if ff ist not running, there's no task as well.

if ff runs, there's a single ff-task.

so like it's supposed to be :)
I am also experiencing this, but it leads to a much larger problem.

I insatlled FF2 ages ago.  Works great.  Double-clicking an HTML file on my hard drive would open Firefox.  Right click and select "open with" and choose Firefox and it works great.

Today I installed Firefox3 using this process:

1. Open FF2, create new profile, call it FirefoxV3, close Firefox.

2. Install Firefox 3 to C:\Program Files\Mozilla Firefox 3\firefox.exe, but don't run it once the installation is complete

3. Update all shortcuts on my computer so FF2 shortcuts run ".../mozilla firefox/firefox.exe" -P FirefoxV2

4. Update all shortcuts on my computer so FF3 shortcuts run "../mozilla firefox 3/firefox.exe" -P FirefoxV3.  Essentially this opens FF2 with my FF2 profile and FF3 with my FF3 profile.  Now I can run FF2 and FF3 on the same computer, but not at the exact same time.  I'm leaving out all mention of -no-remote, which I toyed with, because it doesn't affect my problem and I've removed all traces of it from my computer (e.g. shortcuts)

So now I have FF2 and FF3 installed.  I run FF3 and it says "not your default browser" so I set it as my default browser.

I double-click on a HTML file on my hard drive and nothing seems to happen.  However, looking at Task Manager I see that an instance of /mozilla firefox 3/firefox.exe is running, but no window has opened up.  It is only using 10,678KB of memory.  I can replicate this problem over and over with the same result, however the amount of memory it's using sometimes varies slightly (a few K).

I right click on the HTML file and select "Open With", click Browse and locate /mozilla firefox 3/firefox.exe as the application I want to use, hit OK, and try double-clicking my HTML file again.  Same problem.

I right click on the HTML file again and test it this time by changing the default app to /mozilla firefox/firefox.exe and now when I double click that HTML file it opens up FF2 asking me which profile I want to use (since no -P FirefoxV2 parameters could be included when I specified the default app for an HTML file).  I choose a profile and it opens the page.

As another test, I opened my Windows Folder Options (Windows Explorer - Tools - Folder Options - File Types (tab)) to set the default action for when I double-click an HTML file.  I click Browse and locate /mozilla firefox 3/firefox.exe as the application I want to use, hit OK, and try double-clicking my HTML file again.  Same problem.

So to conclude, if I set FF2 to be my default app for when I double-click an HTML file, it works fine.  This is also the case if I right click the HTML file and select "Open With" and specify FF2.  If I try opening the HTML file with FF3, firefox.exe starts up but hangs.

Thinking it could be a problem with my Windows account settings, I tried all of this on another Windows account on this computer and still experienced the problem just the same.  I am currently running Windows XP Professional SP3.
(In reply to comment #4)
>...
Try reinstalling Firefox 3 and set it as your default during install in case some of the registry settings aren't correct. Also, try opening by double clicking the html file as well as using open with after doing the above.
Thanks for the quick response.

I tried re-installing Firefox 3 and doing as you said, to no avail.

I also tried replicating the whole situation on another computer running the same OS and had the exact same problem.  I spoke with someone on IRC last night to see if they could replicate it and they said they couldn't, but I'm skeptical that they weren't doing quite the same thing I was doing.

Back to my main computer, I also tried uninstalling Firefox 2, which fixed my problem.  I was then able to double-click an HTML file and open it, or open it using the Open With command.  So that fixed that; however, I no longer had Firefox 2 installed anymore, so it's not really a solution.

I then thought of reversing my original installation by doing Firefox 3 first, then installing Firefox 2.  So I uninstalled Firefox 3 so I had NO Firefox installed, then installed Firefox 3 again according to your instructions (opening HTML files still worked, but again no Firefox 2 installed), then installed Firefox 2 next, and the problem was back.

So, overall it's clearly a conflict between Firefox 2 and Firefox 3.

As a side note, if it matters, when only Firefox 3 was installed and I could succesfully open HTML files I went to my Windows Folder Options and looked at the default action for opening an HTML file and nothing had changed since when Firefox 2 was installed.  The following settings were being used:

Action = open
Application used to perform the action = "C:\Program Files\Mozilla Firefox 3\firefox.exe" "%1"
Use DDE = checked
DDE Message = "%1",,0,0,,,,
Application = Firefox
DDE Application Not Running = (empty)
Topic = WWW_OpenURL

I'm not sure what most of that means though.  At one point I tried adding (without quotes) "-P FirefoxV3" to the command line arguments for the firefox.exe application path, but that didn't help and any time I would attempt to open an HTML file it would say the file couldn't be found.

Thanks again for your help!

I think this was fixed by the removal of DDE so resolving as wfm. If you are still experiencing this bug please comment in this bug or better yet please file a new bug. Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.