If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

In <FilterEditor.xul>, "Warning: Failed to load overlay from chrome://messenger/content/msgFolderPickerOverlay.xul."

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
General
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: sgautherie, Assigned: Joey Minta)

Tracking

({regression})

Trunk
Thunderbird 3
regression
Bug Flags:
blocking-thunderbird3.0a2 +
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008062303 Thunderbird/3.0a2pre] (nightly) (W2Ksp4)

1. Start TB.
2. Tools > Message Filters... > New
2r.
{{
Warning: Failed to load overlay from chrome://messenger/content/msgFolderPickerOverlay.xul.
Source File: chrome://messenger/content/FilterEditor.xul
Line: 0
}}

***

With a new profile, I also get
{{
Error: no element found
Source File: chrome://messenger/content/msgFolderPickerOverlay.xul
Line: 1

Error: gSearchTermList is null
Source File: chrome://messenger/content/searchTermOverlay.js
Line: 254
}}

All 3 might be related or different bugs:
first, fix the overlay load, then, we'll see...
Flags: blocking-thunderbird3.0a2?
(Assignee)

Comment 1

9 years ago
Created attachment 326423 [details] [diff] [review]
patch v1

This is another one of those bugs that's not visible in my/philor's cvs builds, but does show up in tinderbox builds.  This is also a classic example of the problems that happen when you include a whole overlay instead of just the files you need.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #326423 - Flags: superreview?(bienvenu)
Attachment #326423 - Flags: review?(bienvenu)

Updated

9 years ago
Attachment #326423 - Flags: superreview?(bienvenu)
Attachment #326423 - Flags: superreview+
Attachment #326423 - Flags: review?(bienvenu)
Attachment #326423 - Flags: review+
applying this patch fixes bug 439763 for me.
Note: i did notice that on my mac the xul elements in the actions area scale up when the panel width is increased (by dragging the bottom right handle), but then don't scale down when the panel width is shrunk (until the dialog gets closed & reopened).
(Reporter)

Updated

9 years ago
Blocks: 439763
(Reporter)

Comment 4

9 years ago
(In reply to comment #2)
> applying this patch fixes bug 439763 for me.

They are duplicates actually (= I'm seeing bug 4439763 symptoms too.);
but mine has the patch and yours has the blocking flags ;->
Flags: blocking-thunderbird3.0a2?
Keywords: regression
OS: Windows 2000 → All
Hardware: PC → All
carrying flags over here (patches w/ reviews trump all). I'll dupe 439763.
Flags: blocking-thunderbird3.0a2+
Flags: blocking-thunderbird3+

Updated

9 years ago
Duplicate of this bug: 439763

Updated

9 years ago
Whiteboard: [ready to checkin]
(Reporter)

Updated

9 years ago
Blocks: 436630
No longer blocks: 439763
(Assignee)

Comment 7

9 years ago
Patch checked in.

Checking in mailnews/base/search/resources/content/FilterEditor.xul;
/cvsroot/mozilla/mailnews/base/search/resources/content/FilterEditor.xul,v  <--  FilterEditor.xul
new revision: 1.90; previous revision: 1.89
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008062503 Thunderbird/3.0a2pre] (nightly) (W2Ksp4)

V.Fixed

The error I was getting on second opening is gone too:
{{
Error: SetFolderPickerElement is not defined
Source File: chrome://messenger/content/searchWidgets.xml
Line: 515
}}
Status: RESOLVED → VERIFIED
Whiteboard: [ready to checkin]
(Reporter)

Comment 9

9 years ago
(In reply to comment #3)
> Note: i did notice that on my mac the xul elements in the actions area scale up

Bug 399771 ;-)
You need to log in before you can comment on or make changes to this bug.