HTML downloads Instead Of Loading in the Browser

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: xedits, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The HTML Page downloaded when I tried to open an Album. I have seen the same happening when I opened an ASP page in ICICIdirect.com. I am not quite sure if the same can be reproduced.

I use Scribefire, Stylish, Foxmarks and Password Exporter

Reproducible: Sometimes

Steps to Reproduce:
1. Open Picasaweb.google.com 
2. Signin and Open an album
3. It download the HTML page.
Actual Results:  
It downloaded the page?
This can be an error on the server or Firefox.
Do you get this always or only sometimes ?
Do you use a proxy, Do you use a firewall which modifies the content ?

Can you reproduce this with Firefox running in the Firefox safemode ?
- http://kb.mozillazine.org/Safe_mode
Component: Download Manager → General
QA Contact: download.manager → general
(Reporter)

Comment 2

10 years ago
The error seems to fixed when running in the safe mode. It may be an issue with one of the addons. 

I encountered this error only twice in 10 years :).

I don't use proxy neither do I use a firewall that changes my content. 
Version: unspecified → 3.0 Branch
Difficult to test if you got this only twice in 10 years.
A few Php installations are also sending the wrong content type if the page is overloaded and that results in such a download dialog.
marking wfm
Please reopen if you have steps to reproduce :-)
This is usually a server issue, it sends the wrong content-type and you will not see this with IE because it does content sniffing
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.