Find a specific bug requires search words

RESOLVED DUPLICATE of bug 385910

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED DUPLICATE of bug 385910
10 years ago
10 years ago

People

(Reporter: Doug Vetter, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080418 Ubuntu/7.10 (gutsy) Firefox/2.0.0.14
Build Identifier: 

2.x Bugzilla used to allow users to find all open / closed bugs for a given product via the "Find a Specific Bug" search tab.  If the user left the "Words" field blank, they'd simply get a full list of open / closed bugs.  

At some point (I believe 3.0), the behavior of this form changed to require a user to enter something in the "Words" field.  I believe that defeats the purpose of this simple interface.

We either need an option to allow a blank Words field or we simply need to turn that "feature" off.  A query of "all" open / closed bugs via this simple interface is a legit query and should be allowed.

Reproducible: Always

Steps to Reproduce:
1. Click on Search page link.
2. Click on "Find A Specific Bug" tab on the search page.
3. Select "open" from the Status drop-down menu.
4. Select "All" or any other product listed on the Product drop-down menu.
5. Leave the Words field blank.
6. Click Search.

This will result in a browser dialog that says "The Words field cannot be empty..."


Expected Results:  
My contention is that the Words field SHOULD be allowed to be empty, as it was in pre-3.x Bugzilla.  So, if I select All products with a blank Words field it should return ALL bugs for ALL products.  Simple as that.  

Sure, I can use the "Advanced" dialog to perform the equivalent query, but many of our users prefer the simpler interface of the "Find a Specific Bug" dialog.

Comment 1

10 years ago
This parameter already exists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385910
You need to log in before you can comment on or make changes to this bug.