Status

enhancement
RESOLVED DUPLICATE of bug 190298
11 years ago
11 years ago

People

(Reporter: kevin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: 

I propose a new feature that would allow people to rename attachments.

The rationale is that often the filename you're attaching is an internal filename that has no relationship to the client. You want to keep it as that filename on your computer, but would like the client to see a more friendly name.

Currently, you have to copy the file, rename it and then send that one. If the rename attachment was an option you would not need it.


Example User Scenario:
A business is sending on a proposal to a client.
They go to attach document 08-06-22_BX.pdf, btu realise it's not friendly.
They could then rename the document to ACME_Project_Proposal.pdf within Firefox and send it as that name, so it's more understandable to the client.

Reproducible: Always
Reporter

Comment 1

11 years ago
This is a suggested UI for this feature request.

Shown here is the modified right-click menu you get when clicking on an attachment.

Comment 2

11 years ago
that's already present in Thunderbird 3.0, which is in early alpha
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 190298
You need to log in before you can comment on or make changes to this bug.