Closed Bug 441546 Opened 13 years ago Closed 12 years ago

the spell checker is inconsistent in fire fox 3. It works some times, and does not work other times. I noticed that it particularity does not work in Gmail. Th problem is that it does not even find the misspelled word.

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: amadondellerba17, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

The spell checker is simply inconsistent when it checks words. Some times it does not even pick up the misspelled words 

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
i've noticed this behavior too.

steps to reproduce:
1. log into gmail and click 'Compose Mail'
2. in the to field put 'gregoryba@gmail.com', in the subject field put 'test'
3. in the message body put the word 'similiar'
4. left click on the word 'similiar' in the message body

expected result:
a spelling suggestion should pop up.
Here's another test I've run...

Steps to reproduce:
1. In firefox3, go to http://mail.google.com/ and log-in to a gmail account
2. Click 'Compose Mail', then, on the right hand side of the screen, click the button to open the composer in a new window.
3. In the 'To:' field put 'gregoryba@gmail.com', in the 'Subject:' field put 'test'.
4. In the message body put the word 'gramatical' (sic).
5. Left click on the word 'gramatical' (sic) in the message body.

Expected Result:
A spelling suggestion should pop up.

Actual Result:
A spelling suggestion DOES pop up.
Works for me. 

If you type a space after "gramatical," Firefox knows you've typed a word and will spell check it. If you haven't typed a space yet, Firefox won't check the word.

If there's another problem, and you can reproduce it with a series of steps, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Attached patch gay pornSplinter Review
You need to log in before you can comment on or make changes to this bug.