Closed Bug 44156 Opened 19 years ago Closed 19 years ago

Stand Alone Window: Message menu should match spec

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED INVALID
mozilla1.0

People

(Reporter: nbaca, Assigned: timeless)

References

()

Details

Build 2000-06-27-08M17: NT4
Haven't check linux or mac yet.

Overview: When viewing a message in the Stand Alone window, the Message menu 
should:

1. Enable
a. .Add Sender to Address Book (depends on bug# 10860, should remove dot)
b. .Add All to Address Book (depends on bug# 10860, should remove dot)
c. .Ignore Thread (depends on bug# 16919, should remove dot)
d. .Watch Thread (depends on bug# 16920, should remove dot)

2. Add
a. 'Change Priority to' should appear after 'Mark'
b. Change Priority submenu items
- Lowest
- Low
- Normal
- High
- Highest

3. Change
a. Mark|As Read should have checkmark to toggle between 'As Read' and 'As 
Unread'
b. Mark|Flag should have checkmark to togge between 'Flag' and 'Unflagged'
Keywords: nsbeta3, ui
QA Contact: lchiang → nbaca
Update to 1c and 1d.
c. .Ignore Thread (menu item should be removed, bug# 44174)
d. .Watch Thread (menu item should be removed, bug# 44174)
Target Milestone: --- → M18
I'm working on 3, I might have already done 1cd
Depends on: 10860, 16919, 16920
OS: Windows NT → All
Removing the nsbeta3 nomination.  These will be condensed into a smaller number 
of bugs and then renominated.  
Keywords: nsbeta3
Stealing from putterman.
Assignee: putterman → timeless
Target Milestone: M18 → M21
accepting.
Status: NEW → ASSIGNED
Target Milestone: M21 → mozilla1.0
Marking Invalid.

It is a dupe of bug# 76247 which is basically a summary bug (it covers Stand 
Alone: all menu items, mnemonic and accelerator issues in the same bug). The 
reason for marking it Invalid is because I don't want to create more noise in 
the summary bug. Please go to bug# 76247 for a recent status.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.