Shift-Alt switches keyboard layout - undocumented(?), should be made optional

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Joerg Starkmuth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 20080421

It took me quite a while to find out that the apparently random changes of the keyboard layout in TB were actually caused by accidentally pressing Shift-Alt. I could not find a meaningful documentation of this feature (if it is one) anywhere, nor instructions how to turn it off - because for me (and probably most other users) it serves no useful purpose, but is simply annoying. Please consider making this optional, disable it by default, or at least document it somewhere and explain its purpose.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I don't believe thunderbird deals with keyboard layouts; this would be an issue with the configuration of the operating system or other software affecting it. These links may be helpful:

http://www.microsoft.com/globaldev/DrIntl/faqs/kbdfaq.mspx#E5C
http://www.microsoft.com/windowsxp/using/setup/winxp/yourlanguage.mspx

Comment 2

10 years ago
It's done by Windows.

On Windows XP, see Start->Control Panel->Regional and Language Options. Then select Languages->Details. In the new Text Services Window, select Key Settings (maybe only possible if you have a Language Bar ???). It's the first hot key.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

10 years ago
OK, thanks a lot. I only encountered this in Thunderbird, and for some reason it was switched back automatically when I restarted TB, so I never hit on the idea it could be a function outside TB. Resolved for me, too.

Updated

10 years ago
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.