Bookmark > Organize Bookmarks loses place if Library already open

RESOLVED DUPLICATE of bug 329853

Status

()

RESOLVED DUPLICATE of bug 329853
11 years ago
10 years ago

People

(Reporter: info, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008062306 Minefield/3.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008062306 Minefield/3.1a1pre

If your Library window is already open to a bookmark folder, then Bookmark > Organize Bookmarks and its keyboard accelerator lose your place in the library navigation tree pane.

My use case is I'm re-visiting a subset of the pages in a bookmarks folder (e.g. "To Follow up" or "My recent posts").  I want to open bookmarks one after another but don't want to Open All in Tabs.

Reproducible: Always

Steps to Reproduce:
1. Open the Library with Bookmark > Organize Bookmarks.
2. Navigate to a subfolder of your Bookmarks Menu and select a bookmark.
3. Return focus to the main browser window.
4. Choose Bookmark > Organize Bookmarks... or its keyboard shortcut again.
Actual Results:  
Library window pops to top and gets focus (good!), but its navigation tree pane resets to All Bookmarks (bad), losing your place.

Expected Results:  
If you're already browsing bookmarks in the Library window, then the Organize Bookmarks command should not change the state of the Library window, leaving your current location in the navigation tree pane and any selection as is.

FWIW Tools > Add-ons and Tools > Error Console don't change the state of their open windows.

I guess Library is harder because it's multi-purpose: if you're viewing history or tags in it, then the Organize Bookmarks command *should* change the navigation tree pane.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 329853
You need to log in before you can comment on or make changes to this bug.