Scrollbar Thumb does not respond to CSS :active

RESOLVED FIXED in Future

Status

()

P3
normal
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: nbhatla, Assigned: hyatt)

Tracking

({polish})

Trunk
Future
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3-)

(Reporter)

Description

19 years ago
In a continuing effort to make a Macintosh Classic Skin:

On most platforms, mouseDown on a scrollbar thumb provides the user 
with visual feedback in the form of highlighting the thumb.  Using CSS in 
the scrollbars.css file, I tried to emulate this highliting effect by changing 
the thumb color during the "active" state:

thumb {
  behavior: url("chrome://global/content/xulBindings.xml#thumb");
  user-focus: ignore;
  user-select: none;
  background-color: #9999FF;
  border-right: 1px solid rgb(40%,40%,80%);      /* #6666CC */
  border-bottom: 1px solid rgb(40%,40%,80%);      /* #6666CC */
  border-top: 1px solid rgb(80%,80%,100%);         /* #CCCCFF */
  border-left: 1px solid rgb(80%,80%,100%);         /* #CCCCFF */
  list-style-image: url("chrome://global/skin/scroll-thumb-horiz.gif");
}

 thumb:active {
	 background-color: #6666CC;
 }

However, this style does not produce any effect.  Oddly, though, once in a 
very long while you will see the highlight effect for half a second or so, and 
then it will disappear.

This bug should be fixed for nsbeta3 because the hilite is a polish effect 
necessary for a Classic skin to fit in the OS's GUI.  The bug is jarring and 
destracting for the user, and makes Netscape's interface look cheap and 
hacked together.
(Reporter)

Updated

19 years ago
Keywords: nsbeta3, polish
pushing to evaughan
Assignee: trudelle → evaughan
Keywords: skins
Target Milestone: --- → M21

Comment 2

19 years ago
setting bug status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

19 years ago
Just realized that this bug only crops up when viewing "special" (non-html 
only) sidebars: Bookmarks, What's related, and the top and left panels in 
Mail, for example.  In most other sidebars and regular html panels, the 
thumb gets the :active message just fine.  Hope this helps.
(Reporter)

Comment 4

19 years ago
This bug might only crop up in sidebar panels that have embedded trees.  
Maybe this bug should go to hyatt?
(Reporter)

Comment 5

19 years ago
reassigning to hyatt
Assignee: evaughan → hyatt

Updated

19 years ago
Summary: Scrollbar Thumb does not respong to CSS :active → Scrollbar Thumb does not respond to CSS :active
Whiteboard: nsbeta3-
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M21 → Future
(Assignee)

Comment 6

18 years ago
fixed by 53091 fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Keywords: skins
You need to log in before you can comment on or make changes to this bug.