[MacOS X] Command-C shortcut in URL doesn't copy URL to clipboard

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: theosib, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

I tried (repeatedly) to copy a URL from the location bar by highlighting the whole URL and pressing Command-C, but when I pasted in another app, whatever was in the clipboard previously is what got pasted.  However, selecting Copy from the Edit menu successfully copied the URL to the clipboard.

Reproducible: Always

Steps to Reproduce:
1.  Highlight URL in location bar
2.  Press Command C
3.  Try to paste it somewhere else.
Actual Results:  
Pasted what was in the clipboard before

Expected Results:  
Paste what I tried to copy

Copy from the menu works fine
(Reporter)

Updated

11 years ago
Summary: Command-C shortcut in URL doesn't copy URL to clipboard → [MacOS X] Command-C shortcut in URL doesn't copy URL to clipboard

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a1pre) Gecko/2008062702 Minefield/3.1a1pre

Works fine for me.  Are you using any Firefox extensions?
(Reporter)

Comment 2

11 years ago
No, I was not using any extensions.  I've restarted Firefox a few times since then, and now when I copy a URL with Command-C, it works fine.  When I was encountering the problem, it was 100% consistent.  This looks to be another one of those bugs where Firefox gets into a weird state, and since I don't know how to get into that state, we won't be able to identify the problem.

Oh well.

Comment 3

11 years ago
That's no fun.  If you figure out how to reproduce, please reopen or file a new bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.