Regression: can't view properties/location of current download

VERIFIED DUPLICATE of bug 431521

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 431521
10 years ago
9 years ago

People

(Reporter: Rich Parker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

"New Download Manager: the revised download manager makes it much easier to locate downloaded files, and you can see and search on the name of the website where a file came from."

I *was* able to see the name of the web site where a file came from in Firefox 2 and earlier, but not any more.  There used to be a "Properties" context menu item that showed the URL, but apparently now this information isn't available until a file has finished downloading.  I have completed downloads set to be cleared automatically, so that's no use to me.  Personally, it's more useful to see the URL while the file is still downloading, e.g. if it's coming from a mirror in another country so I can cancel and try a closer one.

Reproducible: Always

Steps to Reproduce:
1. Download a reasonably large file (one that won't finish too quickly).
2. Right-click the entry in the Download Manager.  There used to be a "Properties" item here.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 431521
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.