Closed Bug 441722 Opened 12 years ago Closed 12 years ago

Input button text and select menus are not displayed properly in webpages

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: pikoro, Unassigned)

Details

Attachments

(4 files)

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; FDM; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
Build Identifier: 

After upgrading from FF2 to FF3, input button text no longer appears and form select menu options are displayed as text.  Downgrading back to FF2 resulted in the same problem now being present in FF2.  Tried on a clean profile and problem persists. 

Reproducible: Always

Steps to Reproduce:
1. Install FF3 over FF2
2. Open FF3
3. ???
4. Profit!
Actual Results:  
See details.  

Expected Results:  
Form controls should have display properly

Have tried with a clean profile, no addons loaded, with the default Xp luna theme as well as XP themes disabled.  Went to irc.mozilla.org and solicited ideas or solutions from #firefox, and after much troubleshooting, dom inspections, code viewing, etc.. it was suggested I file a bug report.
In addition to trying a new profile, the reporter also tried uninstalling and doing a clean install.  What is most strange about this bug (aside from there being no apparent cause and the lack of reproduction) is that this only seems to affect content, not chrome.
The reporter lied about trying with a clean profile.
Or we failed to find out if the reporter actually knew what that meant :P
Sorry, assumed "clean" meant no addons installed or enabled.  Perhaps this should be reclassified as a profile corruption bug?
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
I had the same problem when the XPCOMViewer set the following preference:

nglayout.debug.enable_xbl_forms = true

This setting breaks page layout in the described way.
Maybe FF should disable the setting if it does not work or check for the value
when upgrading.

Requesting a REOPEN.
That setting has been removed for months now, if that's what you're worried about.
You need to log in before you can comment on or make changes to this bug.