Closed Bug 441809 Opened 13 years ago Closed 13 years ago

"Highlight all" button is disabled when switching tab

Categories

(Toolkit :: Find Toolbar, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 279022

People

(Reporter: thibault, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9) Gecko/2008052912 Firefox/3.0

When I search with the Find toolbar, if I search a word and enable "Highlight All" it works fine. Then I look something in another tab, then come back to the first tab (where i searched), the "Highlight button" has been disabled.

The text I searched is still in the input field, if I erase it and search something else and enable "Highlight All", both searches are highlighted, which is not coherent with the case where I dont switch tabs.



Reproducible: Always

Steps to Reproduce:
1. Open 2 or more tabs 
2. In the first tab, open the Find Toolbar with Ctrl+F, search "a", and enable "Hightlight All"
3. Switch to the second tab
4. Switch back to the first tab (Notice the "Hightlight All" has been disable)
5. Erase "a" from the search input, and type "e"
6. Press "Hightlight All"

Actual Results:  
Both "a"s and "e"s are highlighted

Expected Results:  
Only the "e"s should have been highlighted

I have several extensions installed, but none of them is related to search or find toolbar (as far as I know).
I'm willing to give more info if needed.

Good luck to you guys.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 279022
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.