Continue reading of file C:\Windows\System32\Macromed\Flash\NPSWF32.dll

RESOLVED DUPLICATE of bug 407958

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 407958
10 years ago
9 years ago

People

(Reporter: tijs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9) Gecko/2008052906 Firefox/3.0

Processmonitor(systinernals) shows that firefox is continue reading from the file NPSWF32.DLL when a flashmovie is loaded. The specific action according to Procmon is QueryNameInformationFile. What follows is a short sample of a long list in procmon:
As you can see the timestamps, the fileoperation is continu happening.

902,"19:06:32,5894258","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
903,"19:06:32,5904227","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
904,"19:06:32,5914353","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
905,"19:06:32,5924425","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
906,"19:06:32,5934576","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
907,"19:06:32,5954264","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
908,"19:06:32,5955935","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"
909,"19:06:32,5964664","firefox.exe","2128","QueryNameInformationFile","C:\Windows\System32\Macromed\Flash\NPSWF32.dll","SUCCESS","Name: \Windows\System32\Macromed\Flash\NPSWF32.dll"


Reproducible: Always

Steps to Reproduce:
Load a flashfile(youtube) in the browser. 
I don't know if it's OS or flasversion independent.
(Reporter)

Updated

10 years ago
Severity: normal → major

Comment 1

9 years ago
Whenever I visited a page with Flash my hard drive would make constant noise. It bothered me because I didn't put those two problems together until I downloaded Sysinternals Suite and came to the same conclusion tijs did. In the span of time between 1:19:26.7874954 - 1:19:35.5219140, the file had been queried 4,018 times!

Comment 2

9 years ago
Just realized his directory was different... I'm running Vista 64 Ultimate, so mine's C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407958
You need to log in before you can comment on or make changes to this bug.