[MARGIN-C]{ib}top margins not carried out through inline elements

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
15 years ago

People

(Reporter: dbaron, Assigned: waterson)

Tracking

({css1, testcase})

Trunk
Future
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][CSS1-5.5.1])

Attachments

(1 attachment)

DESCRIPTION:  Top margins need to be "carried out" through inline elements for
margins to collapse properly.  nsBlockReflowState::RecoverVerticalMargins needs
to have some real code where there is currently "XXX_ib".

STEPS TO REPRODUCE:
 * load attached testcase

ACTUAL RESULTS:
 * no gap between background and border on top side (from P margin)

EXPECTED RESULTS:
 * should have symmetric 1em margins on P, inside the DIV border

BUGGY IN:
 today's Linux build (tree closure)
Meant to give to waterson, since ib stuff.
Assignee: clayton → waterson
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Updated

18 years ago
Keywords: correctness, nsbeta3
Target Milestone: M17 → M18
[nsbeta3-] and FUTURE.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
Keywords: css1
Summary: {ib}top margins not carried out through inline elements → [MARGIN-C]{ib}top margins not carried out through inline elements
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
QA Contact: petersen → ian
The patch in bug 86947 may remove the relevant XXX_ib comment.
Whiteboard: [nsbeta3-] → [nsbeta3-][CSS1-5.5.1]

Comment 6

15 years ago
Testcase worksforme, 2003-08-14-22 trunk Linux

Comment 7

15 years ago
This testcase is worksforme with 2004020909 windows SeaMonkey build. Resolving. 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.