mails with no subject "dissapears" from mailbox view

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: Kim Emax, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Thunderbird 2.0.0.14(20080421) DK version

If I´ve recieved a mail, where the lazy user hasn´t entered a subject, the mail is not visible in the mailbox overview (read or unread). If I want to view the mail i´ve got to search for the sender.

Sorting is by date, unthreaded and descending

Reproducible: Always

Steps to Reproduce:
1. send a mail with no subject
2. recieve the mail
3. click on another mailfolder and go back to the folder, where you recieved the mail. Now the recieved mail is not visible
4. search for the sender (yourself)
Actual Results:  
The mail is "gone"

Expected Results:  
The mail is shown

Comment 1

10 years ago
I believe this is because we're threading by subject, and somehow the thread with a blank subject is messed up. We shouldn't be threading messages with blank subjects together in the same thread, however.

If you do a rebuild index through the folder properties dialog, do the blank subject messages re-appear?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see no problems with empty subjects in threaded mode, and correct threading of different threads with empty subjects.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.