Save tabs dialog prevents quit when I press CMD-Q twice

RESOLVED DUPLICATE of bug 424378

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 424378
10 years ago
10 years ago

People

(Reporter: ed, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

If you press CMD-Q twice (or any even integer more than that), selecting 'quit' or 'save and quit' both do nothing.  

If you press CMD-Q an odd number of times, the same effect happens- until another dialog box appears in which all buttons are working properly.

Reproducible: Always

Steps to Reproduce:
1. Set preferences to - Tabs>Warn me when closing multiple tabs.
and main>When Firefox starts: show my homepage
2. Open multiple tabs.
3. Press CMD-Q twice.
4. Press quit, or save and quit.
Actual Results:  
The Save Tabs dialog box scrolls up and down twice, and Firefox remains open.

Expected Results:  
Firefox should quit when either quit, or save and quit is selected.

Comment 1

10 years ago
Confirmed.  Dialog doesn't work when quickly pressing ctrl+Q twice.

On Linux with KDE here, and it appends a "<2>" to the dialog title. (it's the second window with that same exact title)  However, there is no other dialog.  Clicking "save & quit" does nothing; ctrl+Q again quits and then it restores tabs on next load.  Odd.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → 3.0 Branch

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424378
You need to log in before you can comment on or make changes to this bug.