Animated background images in tables do not render properly

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: pbotsas, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you're using background images or animated background images in tables you 
cannot read the content of the table. The animated background image is splitted 
up into a chaos of colourful lines and dots.

Comment 1

18 years ago
Do you got a URL to provide us with an example?
(Reporter)

Comment 2

18 years ago
I will do. Unfortunately I deleted the files, because it didn't work. So give me 
just a little time to create them again. Thanks.
(Reporter)

Comment 3

18 years ago
Here's the URL you are waiting for:

1) http://www.it-networks.com/TestGecko/tabletest.html
This one should normally show the danish flag (animated) as a table background. 
All the bright-grey entries in the table should have a black-transparent 
background-image.
In Netscape 4.7 [de] the danish flag is showing properly. Although the speed of 
the animation is everything but normal. The black-transparent background-color 
for every entry does not appear. The entries can be red but you have to look at 
them for the whole animation.
In Gecko the danish flag does not appear at all. Every I can see is a colourful 
image changing every second. The black-transparent background does not appear 
again. The entries aren't readable.
In IE4 and IE5 the table is rendered as it is expected.

2) 1) http://www.it-networks.com/TestGecko/tabletest2.html
This one should normally show the danish flag (animated) as a table background. 
All the red entries in the table do not have any background-image.
In Netscape 4.7 [de] the danish flag is separated for every entry. I only have 
specified a background-image for the outer table. The speed of the animation is 
everything but normal. The entries can be red but you have to look at them for 
the whole animation.
In Gecko the danish flag does not appear at all. Every I can see is a colourful 
image changing every second. The black-transparent background does not appear 
again. The entries aren't readable. (same as in 1)
In IE4 and IE5 the table is rendered as it is expected.

Comment 4

18 years ago
WFM Win98SE 2000062820
Have you tried a recent build pbotsas ?

Comment 5

18 years ago
Here's the URL you are waiting for:

1) http://www.it-networks.com/TestGecko/tabletest.html
This one should normally show the danish flag (animated) as a table
background. All the bright-grey entries in the table should have a
black-transparent background-image.
In Netscape 4.7 [de] the danish flag is showing properly. Although the
speed of the animation is everything but normal. The black-transparent
background-color for every entry does not appear. The entries can be red
but you have to look at them for the whole animation.
In Gecko the danish flag does not appear at all. Every I can see is a
colourful image changing every second. The black-transparent background
does not appear again. The entries aren't readable.
In IE4 and IE5 the table is rendered as it is expected.

2) 1) http://www.it-networks.com/TestGecko/tabletest2.html
This one should normally show the danish flag (animated) as a table
background. All the red entries in the table do not have any
background-image.
In Netscape 4.7 [de] the danish flag is separated for every entry. I only
have specified a background-image for the outer table. The speed of the
animation is everything but normal. The entries can be red but you have to
look at them for the whole animation.
In Gecko the danish flag does not appear at all. Every I can see is a
colourful image changing every second. The black-transparent background
does not appear again. The entries aren't readable. (same as in 1)
In IE4 and IE5 the table is rendered as it is expected.

Comment 6

18 years ago
I see three "bugs" reported here:

- Animated background images in tables do not render at all in Mozilla
- Animated background images in tables render incorrectly in Netscape
- Animated background images in tables are slow in Netscape

That first one could be a valid bug, the second and third one are invalid since 
they're about Netscape 4.7 and not about Mozilla.

However, I'll address each, since the second and third also apply to Mozilla.

- Animated background images in tables do not render at all in Mozilla

Windows 95, build ID 2000062608
Linux, build ID 2000062808

Both pages showed the flag in Mozilla. I'll see if I can find someone with NT to 
check this.


- Animated background images in tables render incorrectly in Netscape

Netscape has a quirk with regard to table background images. They're 
inherited into each cell, which is what you see in the second example, unless 
you override them with transparent/other images like you did in the first 
example. Another trick would be to specify background="" for those cells.

IE just renders it into the background of the table, like you saw.

Mozilla normally emulates NS4's behaviour... Backward compatibility and such.

However, when your page is valid HTML 4 (Strict DTD) and you specify the 
following as your first line, Mozilla will do the right thing in the second 
case. (Of course, this breaks support of NS4...):
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" 
"http://www.w3.org/TR/html4/strict.dtd">


- Animated background images in tables are slow in Netscape

Performance under NS4.7, IE5 and Mozilla were comparable, though _slow_ :-(
Does anyone know if there's a bug report for this? If not, it should be filed 
seperately, though I'm not sure if performance can be enhanced much in this 
case.

------------------------

I did see another oddity in Mozilla though, on both linux and Windows... Between 
rows 2 /3, 5/6, 8/9, 11/12 and 14/15 there were small gaps. I'll see if I can 
find a bug report for that.

Comment 7

18 years ago
Both testcases WFM 2000070220 WinNT

Comment 8

18 years ago
Marking this bug WORKSFORME.

pbotsas@it-networks.com, if you still see the problem of background images on 
tables not rendering at all in Mozilla in a recent nightly build, please re-open 
and indicate which build number.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

18 years ago
OK, OK. I had to download the newest build which took me quite too long.

With Build 2000061311 everything works fine.
(Reporter)

Comment 10

18 years ago
I now have Build 20000710.20:

On cells 2/3, 5/6, 8/9, 11/12 there is a padding. The table itself has no
cellpadding (cellpadding=0).

Sorry!
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 11

18 years ago
Yes, sorry. The original bug (no background image showing) seems to have 
been fixed and is why this one was marked "worksforme" (now).

The gaps between the rows is dealt with in bug 45055.

Marking this resolved worksforme again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

18 years ago
OK!

Comment 13

18 years ago
Reopening it seems to be totally red on Table1. Table 2 looks ok but can be seen
redrawing quite clearly.

Platform: PC
OS: Windows 98
Mozilla Build: 2000101214 M18 Trunk Build

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 14

18 years ago
WFM 20001014 CVS Win98

Comment 15

18 years ago
resolving Worksforme with 10/20 mozilla trunk builds on win32, mac and linux
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 16

18 years ago
Verified with 2001-020608.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.