strange interaction with System Preferences' keyboard shortcut mechanism

RESOLVED DUPLICATE of bug 429824

Status

()

defect
RESOLVED DUPLICATE of bug 429824
11 years ago
11 years ago

People

(Reporter: is+mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; he-IL; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; he-IL; rv:1.9) Gecko/2008061004 Firefox/3.0

If I specify a keyboard shortcut for a menu item, the shortcut will only work if the menu is activated first (for example, pressing Ctrl-F2).  

Reproducible: Always

Steps to Reproduce:
1. Open System Preferences
2. Create a keyboard shortcut for some menu item (I used "Reverse Page Direction" set to Cmd+Opt-X).
3. Start firefox and hit your key combination
Actual Results:  
The correct menu is temporarily highlighted as if the key combination would work, but nothing happens. 

Expected Results:  
Actual acction is performed.

As noted above, if I activate the menu by pressing Ctrl-F2 or with a mouse, then the action is performed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.