Mousewheel scrolling crashes browser

VERIFIED FIXED

Status

()

P3
critical
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: zerbey, Assigned: bryner)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Windows NT 5.0; U)
BuildID:    2000062820

When using the mousewheel to navigate the browser immediately hangs.  This is 
using a Microsoft Intellimouse with driver id 5.0.2183.1

Reproducible: Always
Steps to Reproduce:
1. Go to any web site
2. Try to use the mousewheel


Actual Results:  The browser crashes

Expected Results:  The document should scroll

Comment 1

19 years ago
Confirming. For build 2000062820 (same as reporter) in Win98 SE. Open moving 
mousewheel in any webpage, I immediently crash with.

MOZILLA caused an invalid page fault in
module GKHTML.DLL at 016f:60290d77.
Registers:
EAX=00000000 CS=016f EIP=60290d77 EFLGS=00010246
EBX=00000000 SS=0177 ESP=0068f740 EBP=0068f798
ECX=019c3dc0 DS=0177 ESI=01990188 FS=11a7
EDX=0068f6d4 ES=0177 EDI=01a60910 GS=0000
Bytes at CS:EIP:
8b 08 8d 55 0c 52 57 50 ff 91 dc 00 00 00 8b 45 
Stack dump:
0068fa48 0195c3f0 00000000 601ca6ad 019ac198 01a60910 0068fa48 0068f774 00000002 
0068f948 0068fa48 0195c3f0 00000000 00000000 00000000 0068f798 


Setting as New/blocker If you think thats too much, turn it down :)

Severity: major → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
ouch...have fun, bryner :) assume it's related to your recent mousewheel 
cleanup and compatibility with the new trees
Assignee: asa → bryner
Severity: blocker → critical
Component: Browser-General → XP Toolkit/Widgets
Keywords: crash
QA Contact: doronr → jrgm
(Assignee)

Comment 3

19 years ago
Nominating for beta2 since this is a crasher.
Status: NEW → ASSIGNED
Keywords: nsbeta2
over to janc, who's testing mousewheel stuff...
QA Contact: jrgm → janc

Comment 5

19 years ago
ahh is this the same as in 44296 ?
Perhaps i filed a dup
(Assignee)

Comment 6

19 years ago
Can you retest this with a more recent build?  There was a focus-related bug
that was causing crashes like this that is now fixed.
(Assignee)

Comment 7

19 years ago
Marking fixed per email from reporter.

Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
Marking verified per email from reporter.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.